Hello and welcome to our community! Is this your first visit?
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    May 2009
    Thanked 0 Times in 0 Posts

    Question Google App Engine: starting the web server

    It'll be clear after reading this post that I'm a noob at all of this, but I figured I'd point it out before I started anyway...

    Downloaded Python 2.5.4 and the Google App Engine (GAE) SDK and I'm following the "Getting Started" Python tutorial to familiarize myself w/ Python and the GAE process. Everything was fine and happy until Step 4...

    Step 1: Created a folder on my desktop (Windows XP) named helloworld.

    (It said to create a "directory" named helloworld, but I saw the dude in the video just create a folder, so I figured "directory" was just tech talk for folder... is that right/wrong?)

    Step 2: Used notepad++ to create the helloworld.py file and saved it to the folder.

    Step 3: Created the app.yaml file (w/ notepad++) and saved to my helloworld folder (directory?).

    Step 4: (The death of all my hopes and dreams.)

    Starting the SDK webserver....

    First I got stuck on where exactly I was supposed to type the "google_appengine/dev_appserver.py helloworld/" command. I remembered reading somewhere of people complaining that google likes to do everything through the command prompt window (or whatever its called). So I went to start-->run-->typed in "cmd" and it brought it up. (Is that right?) But when I typed in the command (w/o the quotes) it returned:

    'google_appengine' is not recognized as an internal or external command, operable program or batch file.

    So then I changed it to look more like what the dude in the video used instead (and also later tried changing the files to look like his), and typed in...

    dev_appserver.py helloworld/

    and it returned:

    ERROR:root:Application configuration file not found in helloworld/

    That seemed better than the other message, so I googled this error message and found that other people are having this same problem, but I don't know enough and have too many noob questions to figure out the fixes. (I tried them and they didn't work for me.)

    I got helped here at codingforums a few weeks ago on a javascript question and they really broke it down for me, so I thought I'd post this and see if you guys can help me out again.


    Is a folder and a directory the same thing... is the location of the folder on my desktop ok?

    Is the command prompt window correct or is there another place that I should type in the command to start up the web server?

    What's the right command? and/or the right location for the folder and files?

    what else am I doing wrong?

    Any help or suggestions would be appreciated!
    Last edited by nxgn; 06-18-2009 at 09:37 AM.

  2. #2
    New Coder
    Join Date
    May 2009
    Thanked 0 Times in 0 Posts

    Cool Ok figured it out

    This is like the missing semicolon in a PHP file that had me stumped for about an hour last night.

    After playing around with it for a little while, this is what ended up working:

    dev_appserver.py Desktop/helloworld/

    I tried it after noticing that the command prompt line didn't have the "Desktop" part in there.

    Sometimes I'm not sure what's more frustrating... the problem itself, or finding out that the solution was something that stupid.

    Anyway, I hope this helps someone.

  3. #3
    New to the CF scene
    Join Date
    Sep 2009
    Thanked 0 Times in 0 Posts



    Thanks for the tip. I had the same exact problem on my first day trying to run Google App Engine. You solved it. Kudos.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts