Hello and welcome to our community! Is this your first visit?
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Jan 2011
    Thanked 0 Times in 0 Posts

    impossible to install drivers in ubuntu?

    I loved ubuntu, at first. i also love printers and my music equipment. It took a serch of 24 printers, four purchases before I got a printer that it had a driver for.It still won't scan...

    I have downloaded a driver, after a long search, for my line6 guitar signal processor.

    In have spent hours trying to decipher the indtructuions which require knowledge of perl and the control panel,
    here are the instructions:

    The cleanest way to install the driver is to build and install an RPM package.
    This takes care of removal of old versions and proper loading of the driver.
    Type the commands

    rpmbuild -tb line6usb-0.8.1.tar.bz2
    rpm -U /usr/src/packages/RPMS/i586/line6usb-0.8.1-1.i586.rpm

    The second command requires root privileges. You might need to change the path
    if you are using a system different from SuSE for the i586 platform.

    Source installation

    If you are not familiar with RPM or prefer manual compilation, you can use the
    following procedure. Unpack the archive, change to the newly created directory,
    and compile/install the driver:

    tar xjf line6usb-0.8.1.tar.bz2
    cd line6usb-0.8.1
    make install

    This will compile the driver and install it in the module directory, so the
    driver should be loaded automatically as soon as the Line6 device is connected.
    If it doesn't, you can load it manually with

    modprobe line6usb

    You need root privileges to install and manually load the driver.


    When I tried to build the RPM using perl in the control panel. it did. But when i tried to use it it said bad address and said to use "alien" to install drivers.

    I installes "alien". It appears nowhere.....I don't know what I was supposed to do after it installed...

    the other commands only get "bad address".when i do
    cd /home
    it works.
    cd /home/any other folder
    gets error message

    Please help!

  2. #2
    New Coder
    Join Date
    Jan 2011
    Thanked 0 Times in 0 Posts

    alien from control panel

    perhaps this is not the right place to post this.
    For Slackware users:

    After you unpack the alien_6.x.tgz

    tar xvfz alien_6.x.tgz

    you cd into the alien-6.x dir and do 'make install'. After doing this
    you can remove the alien-6.x dir. So, cd ../

    rm -rf alien-6.x

    With alien installed, you now want to install the alien-extra.tgz.

    Copy (cp) or move (mv) alien-extra.tgz to / and then cd / and

    tar xvfz alien-extra.tgz

    Or from / you can use pkgtool. If you enter pkgtool, up will come a
    window and you pick the first choice (Current). You will be asked if
    you want to install alien-extra. Saying Yes (then pick OK) and it will
    be installed.

    You are now ready to convert rpm, deb, and slp files into tgz files
    (see below).

    NOTE: To run the current rpm's from Red Hat 5.1 and 5.2 under Slackware
    3.5 (3.4), you will further need to download glibc-2.0.7-14.tgz.
    To install the glibc files, you 'cp glibc-2.0.7-14.tgz /' and then
    'tar xvfz glibc-2.0.7-14.tgz' (or use pkgtool to install).

    If you are running Slackware 3.6 or Slackware-Current you
    will not need to install the glibc-2.0.7-14.tgz.

    REMARK: If you are running Slackware 3.5 (3.4 or earlier) and Alien fails
    to work, you can try the following:

    'cd /usr/lib' and

    mv hidden_libc-2.0.5.so libc-2.0.5.so
    mv hidden_libc.so.6 libc.so.6

    Then, ldconfig, and try Alien again.

    For Red Hat users:

    After downloading alien-6.x.noarch.rpm and alien-extra.rpm, to install
    you only need to do

    rpm -ivh alien-6.x.noarch.rpm

    (See the next Note if you are installing under Mandrake-6.0)

    rpm -ivh alien-extra.rpm

    Note: If you are running Mandrake-6.0, you'll also need to download
    ncurses3-1.9.9e-9.i386.rpm (you can download from my site
    ftp://ykbsb2.yk.psu.edu/pub/alien) and install

    rpm -ivh ncurses3-1.9.9e-9.i386.rpm

    before install the alien-extra.rpm.

    You are now ready to convert tgz, deb, and slp files into rpm files
    (see below).


    With the above completed, all the needed files are installed and you can
    now apply any of the following:

    To convert a tgz (or tar.gz) file to a deb or rpm enter:

    alien --to-deb filename.tgz (or alien -d filename.tgz)

    alien --to-rpm filename.tgz (or alien -r filename.tgz)

    To convert a deb file to a tgz or rpm enter:

    alien --to-tgz filename.deb (or alien -t filename.deb)

    alien --to-rpm filename.deb (or alien -r filename.deb)

    To convert a rpm to a tgz or deb enter:

    alien --to-tgz filename.rpm (or alien -t filename.rpm)

    alien --to-deb filename.rpm (or alien -d filename.rpm)

    REMARK: To work with slp make sure you have bzip2 files installed.

    To convert a slp to tgz or rpm enter:

    alien --to-tgz filename.slp (or alien -t filename.slp)

    alien --to-rpm filename.slp (or alien -r filename.slp)

    To convert a rpm or tgz to a slp enter:

    alien --to-slp filename.rpm

    alien --to-slp filename.tgz

    can somone simplify this?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts