View Full Version : PHP file upload issue

10-28-2006, 03:15 AM
I'm trying to develop a simple Flash video upload site for a client and I've run into something I haven't really dealt too much with: an automated user upload page. I'm starting off at the simplest level by just trying to make a page that lets you upload a file up to a 100k, and its giving me back errors. I'm guessing this may be because I need to activate some sort of permission on my web space to be able to write, but it also might be something with the code.

Here's what I have made so far with uploader.php:

// Where the file is going to be placed
$target_path = "uploads/";

/* Add the original filename to our target path.
Result is "uploads/filename.extension" */
$target_path = $target_path . basename( $_FILES['uploadedfile']['name']);

$target_path = "uploads/";

$target_path = $target_path . basename( $_FILES['uploadedfile']['name']);

if(move_uploaded_file($_FILES['uploadedfile']['tmp_name'], $target_path)) {
echo "The file ". basename( $_FILES['uploadedfile']['name']).
" has been uploaded";
} else{
echo "There was an error uploading the file, please try again!";

By the way, the script was taken from: http://www.tizag.com/phpT/fileupload.php?MAX_FILE_SIZE=100000 (http://www.tizag.com/phpT/fileupload.php?MAX_FILE_SIZE=100000)

I've tried modifying the $target_path to go to the exact path of the site and not go into the uploads folder, but the folder before that which is "fullScreen".

The result of choosing a file and uploading is "Warning: move_uploaded_file(uploads/Buzzy Beetle.gif): failed to open stream: Permission denied in /home/vectors/public_html/fullScreen/uploader.php on line 14"


'Warning: move_uploaded_file(): Unable to move '/tmp/phpzjYA8l' to 'uploads/Buzzy Beetle.gif' in /home/vectors/public_html/fullScreen/uploader.php on line 14
There was an error uploading the file, please try again!"

If you want to see and try the upload page for yourself, it's right here. (http://www.vectorsector.net/fullScreen/upload2Test.html)

I just want to note that all the permission settings for the upload folder are all checked, including world.


10-28-2006, 02:46 PM
the destination must be a complete address, so $_SERVER['DOCUMENT_ROOT']."/gallery/".$newname

just as $_FILES["filename"]["tmp_name"] willl be something like c:\winnt\temp\45334.tmp

$newname = "picture1.jpg";

function upload($newname){
$temp = $_FILES["filename"]["tmp_name"];
if(move_uploaded_file($temp, $_SERVER['DOCUMENT_ROOT'].'/gallery/'.$newname)){
return true;
return false;

10-28-2006, 09:17 PM
I checked them all. Set to 777. Tried the form last night, didn't work. Today it worked!!! What?! Does this mean it takes some amount of time for it to work after permissions are changed? I just dont understand. Thanks for all your help though. I wouldn't of known to do this in the first place.