View Full Version : Apache Still Not working

Carter McArthur
06-21-2006, 10:46 PM
I have been trying to install Apache, PHP and MySQL on my XP machine.

At first I had Apache and PHP working but kept having MySQL problems.

I went to a bunch of other boards, posted, followed the feedback and really got screwed up where nothing worked. Finally out of desperation, I remove all the programs, and started re-installing.

Now after I install Apache I always get this error:
[error] (OS 2)The system cannot find the file specified. : No installed service named "Apache2".

This acts like a Windows registry problem, but when I open the registry in REGEDIT, I can see the entries for Apache there. I even went so far, on the last install, to clean out all Apache entries in the registry.

I am install 2.0.55 with the MSI file and I think there is something missing in that install library set, causing this error, but not sure.

Too green on Apache to know.

Can I get some help, I'm loosing my mind on this!


06-27-2006, 05:29 AM

I'm also trying to install Apache, PHP, and MySQL locally. Can work online, quite well but need the debugging for PHP, to see errors. Have Apache up and running, I think, at least no Apache run errors, but PHP running on the following code:
$headstr = '<html><center><h1>Testing Apache Server</h1>
<b>HTML Version</b></center><body>Header<br>';
$footstr = '<br>Footer</body></html>';
echo $headstr;
echo $footstr;
?>Give the following output
Testing Apache Server
HTML Version
'; $footstr = '
Footer'; echo $headstr; phpinfo(); echo $footstr; ?>Also in my PHP Editor the PHPinfo() command shows only text and not the table with colors, etc.

Assume it is the lack of linking a library but wondering if it is Apache side or PHP side?

Can anyone help? Config files are attached!


06-27-2006, 06:14 AM
Unless you really want to learn how to install all of it why don't you just use one the ready made packages that include them? My fellow moderator firepages makes one called PHPDev


06-27-2006, 04:28 PM
Like what was just posted, their are a few pre built ones. Their is another called Wamp Server, http://www.wampserver.com/en/index.php . Most of these makers though say they are for development though, and if you have problems running it as a real server, then they will tell you you are SOL.

If you are in need of a good PHP book, try PHP and MySQL Web Development by Luke Welling and Laura Thomson. It is like $32, but it is worth it if you need more PHP training and need to know how to set up the PHP and MySQL with Apache; the Apendix A shows you how to do this with Linux and Windows in detail. It shows you all the config mods you need to make in detail and explains them. I have set up my server many times to this book, and never had a problem. I dunno, if you already know PHP well, it may not be worth buying, but the book is excellent, good reviews, and is a good reference.

06-27-2006, 05:39 PM
try installing XAMPP from www.apachefriends.org

it has: PHP. MySQL, PERL in it, and it is easy to control... if you know how to work Server-Side scripts from localhost not by double clicking, which took me a while to figure out :\

06-27-2006, 08:57 PM
try installing XAMPP from www.apachefriends.org

it has: PHP. MySQL, PERL in it, and it is easy to control... if you know how to work Server-Side scripts from localhost not by double clicking, which took me a while to figure out :\

This does not fix my problem!


06-27-2006, 09:38 PM
Please see my post at:




06-28-2006, 12:03 AM
http://a51.neostrada.pl (should be http://a51.phpweekly.net if it works).

08-01-2006, 01:37 AM

Still fighting this! Had to undo all the XAMPP bullkrap as it did bad things to my machine and would not install where I told it to go. Anyway, I installed Apache (2.0.55) and PHP (5.1.4) on Win2K. Localhost was working and now, without changing anything I now keep getting:


You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.55 (Win32) PHP/5.1.4 Server at localhost Port 80

I was always getting a SAVEor OPEN dialog before on .php files so was coming back to address that when I found this error.

Need to get this going as I have code to write.



08-01-2006, 01:53 AM
see httpd.conf for the following:
If apache fails to find any of the files in DirectoryIndex in the requested directory you will get a forbidden error unless you allow to show the contents of the folder.