View Full Version : CDBOOT: couldn't find NTLDR

02-07-2006, 09:19 PM
I've got a used Compaq system that I'm trying to get up and running (for use as a web server) I personally don't like anything made by HP/Compaq, but it's a friend's old system.
The problem I'm having is any windows XP boot CD that I use will either NOT boot up at all, or will (what seems like) randomly display this error:
CDBOOT: couldn't find NTLDR
I have tried about 4 different CDs and they all do the same thing. This also includes Win2000. But Windows 98SE boot works fine!

I have tried the WinXP and Win2000 CDs on 2 other systems (Desktop and Laptop) and they work fine. (They give me the "press any key to boot from CD...." message)

So this is obviously a problem with the compaq system.
Can anyone help me?

Thanks in advance

02-07-2006, 09:39 PM
It sounds like a craped-out CD ROM drive on the Compaq. I know, a Compaq piece going bad? But that never happens! Oh wait yes it does. See if you can grab a new CDROM drive and throw it in and that should at least solve the CD problems, I hope.

EDIT: Oh yeah, if you want to get a good one, I suggest a Lite-On brand. They work really well for reading bad CDs, so it helps to remove any possible problems from a small scratch on the CDs surface.
For CD ROMS: http://www.newegg.com/Product/ProductList.asp?Submit=BROWSE&manufactory=1336&bop=and&InnerCata=55

For CD/DVD Burners: http://www.newegg.com/Product/ProductList.asp?Submit=BROWSE&manufactory=1336&bop=and&InnerCata=5

02-07-2006, 09:44 PM
Some older CD-ROM drives don't support booting from CD I believe. You will need to get a newer one which you know works. Also make sure the IDE cable connecting your CD drive to your motherboard is decent and is of a good quality.

02-07-2006, 09:55 PM
Thanks for the replies:thumbsup:

I don't think the problem is the CD-ROM because I have used the same one in another system to boot and install.

Though now, I've managed to get this install to work, but I'm using floppies to do the initial boot, and then "redirect" the boot to the Cd-ROM. Which is currently working. It's formatting the C: drive at the moment, but when the install is finished, I'll put in a better CD-ROM to test eveyone's theory.

If anyone is curious, or if this maybe helps, it is a Compaq DeskPro EN
(This is what it says on the top panel cover)

02-07-2006, 11:04 PM
Did you make sure the BIOS was set to boot from the CD-ROM before the hard drive? It kinda sounds like that was the source of the problem.

02-07-2006, 11:26 PM
I considered that, and yes i did check, several times actually.
besides, if it wasn't set to boot to CD-ROM, it would just boot to Hard drive and not show an error right?

02-08-2006, 12:11 AM
If you tried to boot to the hard disk and it was blank, you'd either get "Operating System not found" or a flashing _ and nothing thereafter.


02-19-2006, 07:05 PM
sorry about the long delay, but it turns out it was just a faulty CD-ROM..i've got a DVD-RW in place until I can get my hands on something permanent

but thanks everyone for the help:thumbsup: