View Full Version : Provider is not specified and there is no designated default provider.

Aug 22nd, 2005, 03:06 PM
i just bought a brand new server and put windows server 2003 x64 sp1 on it then put sql server 2000 sp4 on that and set up a trusted odbc connection. however, it gave me the following error:

SQLSTATE:IM002, diagnosis:[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

so i made a vbs file (adodb.connection) to see if that could connect to it and it came out with this on the err.number err.description

err.number = 3753
err.description = Provider is not specified and there is no designated default provider.

this even happened when i tried to use a dsnless connection to the old server machine so i dont know if its a problem with whatever is trying to use the connection or odbc or what. please can someone tell me what can i do to fix this problem?

i dont know if this is just a missing driver or something, odbc only has "SQL Server" in the list (C:\WINDOWS\System32\SQLSRV32.dll i think) wheras all my other machines have something like 25 or 30 drivers in the list, but "SQL Server" is the one im trying to use anyway..

iis is not installed on this new server. other machines (with iis and with vbs) can connect to the new server's databases using dsnless or dsn with uid and pwd. also i think asp might have a different err.number for this problem than vbs' 3753

every other place i have looked for people with similar problems has been on a windows x64 system.

Aug 22nd, 2005, 05:45 PM
It might easily be the way you're trying to connect that's the problem.
What's your connection string look like? You need to tell ASP what driver to use, even with a DSN set up.

Aug 22nd, 2005, 10:13 PM
its not asp that im trying to connect with its just easiest to test with asp and vbs (vbs on the machine i have the problem with)

i have tried dsn and dsnless which both work on external machines connecting to the servers mssql but the server itself can make no connections whatsoever

these strings i have tried in vbscript and work on other machines
driver={sql server};server=;database=..;uid=sa;pwd=..;

etc but they make no diff and they all work from other machines anyway (appart from the trusted one of course)

Jan 30th, 2006, 04:46 PM
I am having the same issue.
We set up a new Windows Server 2003 x64 with IIS 6.0 and SQL Server 2000 SP4.
I ported an existing website app over ( that used a global.asa ) to the new server and it seems that the global.asa is not being sourced.
I have tried all the security settings that I can find.
I also found that there are 2 different ODBC admin tools.
The default is the 32bit one, and that only shows the lone SQL driver.
Using the 64 bit one %WINDIR%\SysWOW64\odbcad32.exe
has all the ones you normally see.
I tried setting up DSN's in each one but to no avail.
Having all the connection data in my asp pages works fine, but
I do not want to go back and recode the entire app.
I was wondering what solution you came up with for your situation.

Jan 31st, 2006, 01:24 PM
unfortunately i have yet to find a solution. my asp pages currently use sqloledb for a dsnless, .net works fine, and the closed source c++ app i was running that had to be on odbc had a configuration setting for windows server 2000 mode which made it work on the 32bit odbc (the odbc manager found in syswow64 not system32)

if you do find a proper solution please let me know:(

Feb 15th, 2006, 01:31 PM
Found this on Google and it seems to work :o)

There is no 64-bit version of MSDASQL.DLL which is Ole db provider for ODBC
dirvers. 32-bit software will still work, but if you want to to connect from
64-bit world you need to use an OLEDB provider, in SQL server case it will be

You can also look at this link. http://www.adopenstatic.com/experiments/ConnStringSpeed.asp.

May 22nd, 2006, 08:52 AM
It is possible to run IIS in 32 bit mode. So it can use all the database drivers


say to execute

cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

I used this and it is working fine.