View Full Version : opening cgi-files

07-25-2005, 03:44 PM

I am currently trying to continue someone else's work with cgi files. We are using Apache on a Windows XP machine. Currently I am trying to open his cgi files, located in the cgi-bin. Whether it is with Perl or Notepad, everytime I try to open a file it only opens "MZ[]", that's it.

I know that there is more there because the files are about 150 kb and the webpages work. I can open up other cgi files (examples, etc...) with both of these programs, but not any of his cgi files.

I've tried moving them out of the cgi-bin but I get the same problem. Any Ideas? Thanks.

07-25-2005, 07:02 PM
in windows all executables begin with MZ....

have u tried running those scripts from the command-line ?

07-25-2005, 07:08 PM

Unfortunately when I try and run it from the command prompt it starts to run and then gives me this error:

"Instruction @ 0x00404310" Reference memory at "0x0000000" The memory could not be "Read". Press Ok to terminate and Cancel to Debug.

I'm not sure if he programmed these in c++ or perl. When I downloaded perl, it recognized these cgi files as perl files. I've tried opening them up in VisualC++ 5.0 but with no success so far.

Jeff Mott
07-25-2005, 10:45 PM
The error message doesn't sound like one that would come from Perl. C++ would be more likely, though it could be any language. So what you're opening in notepad is the compiled machine code. You'll have to find where the source files are kept.