View Full Version : Database created but not in mySQL DB table

09-13-2002, 04:24 AM
I am using firepages phpdev and I am trying to create a databse called 'users'. The database gets created, I can add tables to it, etc. However, when I look in the db table of the mySQL database, there is no entry for the 'users' database. As a result, I have no way to identify the user or password, and I am unable to connect to the database - it shows as unavailable. How do I get the database to be defined in the mySQL database table and how do I establish the user and password?


09-13-2002, 04:37 AM
When you say "when I look in the db table of the mySQL database" what do you mean? what db table of the mySQL database? Are you referring to one of the tools that come with phpdev?

By default I believe the username and password are blank. So:

$dbusername = "";
$dbpassword = "";

09-13-2002, 06:15 AM
Yes, sorry, there is a phpAdmin tool. It shows that there is a master database called mySQL. That databse contians 5 tables:


Normally, for each databse you create, an entry is created in the DB table. At least, I can see entires for prior databases I have created, but not for this one. You mention, Spookseter, that by default the user and password are blank. Wouldn't you need to change them in the database I have described above in order to use the user and password for the new database?


09-13-2002, 06:23 AM
The way firepages set things up by default the username and password for the databases you create will be blank. So when you write your connection string you would just have "", "" instead of putting anything in it. Have you changed any settings or configurations since you installed phpdev? Or have you tried connecting with both of those blank?

And when you say it was unavailable did it say something along the lines of that mysql was unavailable? Don't forget to start mysql before you connect to it.

09-13-2002, 06:37 AM
OK, thanks. I know for my last database, I had a password and user set up - I can see them in the mySQL table. How I got them there I dont remember. I will try with blanks... Yes mySQl was up.. OK, Iwill try again........... Ah, sure enough it worked - at least, with user and pwd set to blank, I was able to connect. I got some other error futher along, but at least I got connected. Thanks!