View Full Version : I Hate Windows XP!

05-19-2005, 09:45 PM

I am using Windows XP and I have encountered a problem! (Surprise!). I've seen it on other people's versions of XP too - Every so often the operating system gets it into it's head that a particular file or folder is being used by another application (when it isn't) and stubbornly refuses to delete it (even after restarting the PC)!

Does anyone know why this happens and how it can be cured? (I'm guessing it's something to do with that irritating registry!).

Incidently, I also use Linux and I never have any problems with that which I can't fix! (Nice Linux).


05-19-2005, 09:48 PM
Incidently, I also use Linux and I never have any problems with that which I can't fix! (Nice Linux).


Then why even have Windows? ;)

05-19-2005, 09:50 PM
what file are you referring to? If its a dll, it could still be loaded.

If its an avi file or another media file, the last time you played it, it crashed the player and/or the codec - so it is stuck. Sometimes, renaming and deleting works. try renaming the file to something else.

05-19-2005, 09:52 PM
If it won't delete there are tools such as deleteonboot (cant remember exact name)

I might get rid of XP Pro SP2 off my main box and stick either Windows 2000 Server or Windows Server 2003 Standard/Enterprise because I have found them more reliable in the past.

05-19-2005, 10:09 PM
Thanks for the replies!

It's just a bog standard folder - I've tried renaming it and it won't have it. Still won't delete it! Surely it's just represented in the filesystem by an i-Node number ... (or perhaps windows doesn't work like that).

05-19-2005, 10:51 PM
i have had this prob a few times!, trying zipping the file then deleting/renaming!


dissassociate the file format;

right click / open with / tick always open with this type of prog / choose non- associated program

it may help! :)

05-19-2005, 11:59 PM
I found once that I couldn't remove a folder which was always "write protected or currently in use"

The solution was to run a CHKDSK on the disk in question then degfragged it...for some unknown reason it was deletable after then - must have been corrupt or something :p

05-20-2005, 12:57 AM
When I run into that problem I always just open a command prompt and delete the old fashioned way

del directoryname
del filename

05-20-2005, 03:31 AM
I find WhoLockMe (http://www.dr-hoiby.com/WhoLockMe/index.php) to be quite useful in these situations.