PDA

View Full Version : IE & Firefox agree?!? Netscape doesn't!!



J&J
Nov 19th, 2004, 02:41 PM
Can someone take a look at my site using Netscape 6.2+ before I go insane & let me know what happened?!? :confused:

http://www.jandjwebservices.com

Ok, all I did was made some layout changes & used PHP since it was all just plain html files. Usually, IE requires hacks to look the way I want it to but for the first time ever, Firefox & IE are actually showing the site the way it SHOULD look like -- they are agreeing, and Netscape isn't. :eek:

If you haven't noticed it, the menu width in Netscape sticks out further than I want it to. In IE, it's flush with the page content & stuff. Anyone wanna take a "hacK" at it?

Roy Sinclair
Nov 19th, 2004, 04:41 PM
Ditch Netscape 6.2. Seriously, it's both obsolete and defective. Unless you've got a bunch of users stuck on that browser for some reason there's no good reason to continue to design for it's flaws. In the normal internet population there shouldn't be any Netscape 6.2 users since it been replaced with later versions and those who would have installed it previously would have migrated to the current version of Netscape by now.

wac
Nov 19th, 2004, 05:29 PM
How odd :confused: On my machine, IE and Netscape 7 agree, while Firefox (1.0) has the home menu sticking out. Go figure

chilipie
Nov 19th, 2004, 06:12 PM
Same here. IE displays it fine, but the menu is wider and sticks out to the right in FF.

J&J
Nov 19th, 2004, 07:45 PM
Really?? THis is insane!! :eek:

I have Netscape 7 at work, and the menu sticks out there. IE 5.5 at work shows it OK.


At home, I have Netscape 6.2, and it also sticks out...
Then in IE 6 & Firefox 0.8 (will upgrade to 1 soon), they show it flush.

Weird...

Roy Sinclair
Nov 19th, 2004, 08:05 PM
Whatever else it is, it's related to the "4px" padding you've specified on div.menu because setting that to 0 gets rid of the overlap.

J&J
Nov 20th, 2004, 03:26 PM
Whatever else it is, it's related to the "4px" padding you've specified on div.menu because setting that to 0 gets rid of the overlap.


The 4x is gone, but the prob isn't. Odd....