PDA

View Full Version : div id affecting rendering in IE5?



nki
Sep 7th, 2004, 07:16 PM
OK, so here's an interesting one (and even though I've kind of already got a solution, I'm curious to find out what's going on...)

This is the basic page structure I'm using. Everything's hunkydory until I view it in IE5 and 5.5 - oops! no navigation!

Eventually I end up changing the name of the div that the menu is in from "menu" to something else (in this case just by adding a t on the end) and adjust the css accordingly like this.... Et voila the menu's back again?


Is this really what's going on?
Does IE 5.x object so strongly if I give something an id of "menu"? :confused:

nki
Sep 7th, 2004, 11:38 PM
ha!

we may never know...

In the process of sorting out the rest of the site I've managed to overwrite/ partially edit some of the files the above links refer to. It's all a bit of a mess and I have a working site so I'll quit while I'm ahead and let it be now...

Roy Sinclair
Sep 8th, 2004, 04:11 PM
It wouldn't surprise me to find that "menu" is a reserved word. It's long been established that you shouldn't use reserved words as names so...

nki
Sep 8th, 2004, 04:23 PM
Thanks for that - I'll see if I can track down a list of these reserved words. I've not heard of them before but it sounds like the sort of thing that might have been going on.


...although there's also the very real possibilty that I'd left off a closing tag or something... Glad to here there's an outside chance I can blame it on something else! :)

Thanks again