View Full Version : Java applet can be loaded from some servers, not others

Daniel J.
08-21-2004, 07:19 PM
I'm designing a webpage with frames. Each of the frames contains Javascript and/or Java. When I view the entire page (i.e. frames and all) directly on my compter (typing C:\...\index.htm directly into my web browser--I'm using IE6), it works. However, once I save it onto Windows XP's built in server (and loading the site on http://localhost/.../), one (of two) Java applets stops working, and all I see is the grey box with a red 'X' in the top left-hand corner. The two applets are in different frames. Even when I try to view only the page with that applet, it still does not work.

Interestingly, I tried uploading the page on one webserver and it still didn't work. However, when I uploaded the page onto yahoo's geocities, it works fine. I'm guessing there's some problem with permission or security or something, but as for what it is, or what to do about it, I've not a clue. I especially can't understand why one applet works and the other doesn't...

To take a look, you can check out


this is the page where the applet works

Any help would be much appreciated.

Thanks in advance.

08-24-2004, 03:15 AM
One thing you might do is Check the access rights on the folders that the information is kept.

Daniel J.
08-24-2004, 04:48 PM
fixed the problem.

I changed the name of the folder containing the folder which had the HTML document and the JAVA file. The original name had had an exclamation point in it; once I took that out, the JAVA bit worked. I still don't understand why every other part of the webpage, including parts written in JAVA, JavaScript and HTML, had no problem with the '!'. I didn't do anything to the JAVA app or the HTML file in which it was housed. Regardless, it's fine now...