View Full Version : I can't set up phpMyAdmin to recognize my new root password!

04-10-2004, 11:20 AM
Hi all

I didn't want to change my MySQL root password because I was using it only on my own system. But since yesterday that we made a sort of network and others got connected to me, I thought it's really a good idea to set up a password if I don't want them to login to my MySQL server! So, I used this command at windows shell to change my password (after login in)

SET PASSWORD FOR root@localhost=PASSWORD('my_new_password');

and it works just fine. I tested it in shell and MySqlCC and I had no problem log into my MySQL as root. But then I have the following setting in config.inc.php ( phpMyAdmin configuration file ):

$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'tcp'; // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['compress'] = FALSE; // Use compressed protocol for the MySQL connection
// (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser'] = 'root'; // MySQL control user settings
// (this user must have read-only
$cfg['Servers'][$i]['controlpass'] = ''; // access to the "mysql/user"
// and "mysql/db" tables).
// The controluser is also
// used for all relational
// features (pmadb)
$cfg['Servers'][$i]['auth_type'] = 'config'; // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = ''; // MySQL password (only needed

I changed the last line ( $cfg['Servers'][$i]['password'] = ''; ) to:

$cfg['Servers'][$i]['password'] = 'my_new_password';

and it doesn't work. It tells me:

Your client doesn't support authentication protocol requested by server; consider upgrading MySQL client

So, what does it mean? What am I supposed to do?

04-10-2004, 01:43 PM
just to get back in , set $cfg['Servers'][$i]['auth_type'] to 'http' and login that way , otherwise not a clue , though perhaps its a host issue , try

SET PASSWORD FOR root@"%"=PASSWORD('my_new_password');

04-10-2004, 03:29 PM
This is how I set my root password:

cd C:\Server\mysql\bin\
mysql> use mysql;
mysql> DELETE FROM user WHERE Host='localhost' AND User='';
mysql> QUIT
C:\> C:\Server\mysql\bin\mysqladmin -u root password rootpass

Maybe it will be of some help to you.

04-30-2004, 02:54 AM

I installed SWAMP, and I started toying around in /localhost/phpmyadmin...
I deleted two default users, and set passwords for another two, but everytime I hit "Reload mysql" it all of a sudden looked like I never did a thing! The deleted users came right back! Then I tried deleting even more users and adding a new one, then it denied me access all of a sudden! I entered every password and username... NOTHING. I tried editing the config.inc.php file, putting in all different user names, and authorizations (http, config, etc) and different passwords, or no password... No matter what I do I can't get back into /localhost/phpmyadmin. :mad: I've tried restarting everything, getting the newest phpmyadmin, and reinstalling it... The install.txt doesn't give much help here. I did everything it told me to, and this is where I'm at. I've even searched the forums for similar issues... HELP!

(EDIT: By the way, I'm ULTRA NEW to this in case you didn't know, but I'm not afraid to read volumes to learn what I need to know.)

05-03-2004, 03:44 PM
Well I got it working. I don't know how exactly, but I figured I'd give it another try another day, and whammo: Everything fell into place. Now I'm hosting my own web server, and MySQL is working like a charm. :D

05-03-2004, 05:54 PM
Congratz! I really didn't know any remedy for your case that I didn't answer, but I'm happy that you could fix it. I'm still stuck with my original problem!