PDA

View Full Version : Browsers



Squintz
Aug 6th, 2002, 08:42 PM
What are a list of bnowsers i should Download to make sure my site is compatible with them...

firepages
Aug 6th, 2002, 09:34 PM
depends ;)

definately IE4 or higher
definately mozilla 1
I would suggest Opera as its a popular browser which still has it quirks.

& that covers say 95% of all users


<fan_the_flames>

Do you worry about IE<4 && Netscape4.*

my answer NO, but many will say otherwise, its a philosophical thing, I think the sooner we make outdated browsers unusable the better, that inlcudes everything NS<5 or IE <4 (almost ready to say IE<5 but a fair few peeps still use IE4.*)

What about the others.... well ignoring Lynx and amaya etc, most of the other browsers are built around IE or NS/gecko anyway and should follow the same rules as above.

yes there are still some peeps who use text based browsers & NS2 etc out there but thats a choice they make, if we pander to their needs then all web-pages will be text only for evermore, else you have to prepare seperate content for those users and I do not think its really worth it, they have the option, decent browsers are not expensive.

<fan_the_flames>

ok - its nice and warm.

EDIT::

OK this is from my stats over 9million page views and MSIE>=4 comes in at 93%

MSIE/6 , 58.800 %
MSIE/5 , 33.991 %
MSIE/4 , 0.762 %
MSIE/3 , 0.008 %
MSIE/2 , 0.001 %
Netscape/4 , 1.420 %
Netscape/6 , 0.699 %
Netscape/3 , 0.021 %
Netscape/2 , 0.029 %
Netscape/8 , 0.003 %
Netscape/7 , 0.001 %
Mozilla/1 , 1.417 %
Mozilla/0 , 0.315 %
Opera/6 , 1.651 %
Opera/5 , 0.117 %
Opera/0 , 0.000 %
Opera/v5 , 0.000 %
DA/5 , 0.230 %
DA/4 , 0.029 %
DA/3 , 0.000 %
Googlebot/2 , 0.107 %
MSProxy/2 , 0.127 %
MSProxy/1 , 0.001 %
Konqueror/2 , 0.102 %
Konqueror/3 , 0.063 %
Konqueror/1 , 0.000 %
GetRight/4 , 0.040 %
GetRight/3 , 0.001 %
Galeon/1 , 0.062 %
Galeon/0 , 0.003 %


lol the googlebot visits more often than amaya :)

boxer_1
Aug 6th, 2002, 10:37 PM
Those stats provide some pretty useful / realistic information Firepages. For the most part, I agree with your reasoning, but of course, a lot of this depends on your target audience. IMO, if a user won't take the simple / free step to upgrade their browser, they're probably not going to be much of a factor for someone with a site offering new / cuting edge products / services. They probably still use a straight razor to shave with :rolleyes:. However, if your offering antiques on your site, you might want to accomodate more users with older browsers :D. It all depends on the intent and content of your site and what type of audience you want to accomodate, so there is really no definitive answer to how much you code your site to accomodate legacy browser versions (just my opinion of course).

BTW: You forgot to close your <fan_the_flames> tag opened on line 10...lol (j/k) ;).

Alex Vincent
Aug 7th, 2002, 03:44 AM
Originally posted by firepages
Netscape/8 , 0.003 %

:eek:

totalhosting
Aug 7th, 2002, 05:30 AM
If you check out http://www.alistapart.com you can see how they handle older browsers (it has to do with style sheets0.

You can also check out http://www.webstandards.org/ for opinons in this area.

HTH

Pete