PDA

View Full Version : Image won't show up in Explorer



DHamp
Mar 3rd, 2012, 02:30 PM
I'm pulling my hair out (if I had any). I'm VERY new to HTML and CSS and am learning a ton. What I'm really learning is that IE is terrible. My site works fine in Safari, Firefox, Chrome, Opera and iOS but my header image just won't show up in Explorer. My site is www.dhphotodesigns.com
Any help would be greatly appreciated!

dan-dan
Mar 3rd, 2012, 03:22 PM
It works fine with IE9. I don't have an older version to try it on though, sorry.

DHamp
Mar 3rd, 2012, 03:51 PM
Thanks! Yeah it doesn't work in the older versions when I've tested it. Hopefully not too many people are using those older versions because I am stumped.

ARCLite Studio
Mar 3rd, 2012, 06:05 PM
As i do not have an older version of IE to test on I also can say exactly what the problem is, it does show properly in the latest version, however in looking at the code, I did see one issue that might be your cause:

<img height="118" width="360" alt="DH Photography" src="Images/Main Navigation/DH Logo.jpg">

the "DH Logo.jpg" file name in the src uses a space in the name, IE has had issues in the past about spaces in file names. Try renaming the file to DH-Logo.jpg and change the src= to match the new name. Also be sure to clear you cache in IE.

Let me know if that was your issue.

coothead
Mar 3rd, 2012, 07:16 PM
Hi there DHamp,

and a warm welcome to these forums. ;)

Internet Explorer pre version 9 has a problem displaying JPEG images that have CMYK, rather than the default RGB encoding.
The problem can be resolved by opening the .JPG file in an appropriate image editor.
Either change the mode to RGB and then "Save" or use the "Save for Web" option.

Alternatively, you can use the converted attachment.

coothead

dan-dan
Mar 3rd, 2012, 07:34 PM
Brilliant! I had no idea about either of these bugs.
IE, you never fail to surprise!

coothead
Mar 3rd, 2012, 07:39 PM
Hi there dan-dan,

I believe that the CMYK encoding is used by the printing trade. ;)

coothead

ARCLite Studio
Mar 4th, 2012, 02:22 AM
CootHead,

Excellent catch, i never thought about the CMYK issue. Have not encountered it very often and had forgotten about it (One reason I do all images in PNG). Thanks for the reminder !!