View Full Version : MySQL.Manager of pid-file quit without updating / innodb_force_recovery

10-09-2011, 11:52 PM
My server died, whatewer I did I ended at:

MySQL.Manager of pid-file quit without updating

The suggestion on net was to delete pid file, but the thing was not even there at all.

Killing mysql process & retry did not help.

I knew that prob was probably one inodb table which probaly got "to big"


InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
110203 10:44:59 InnoDB: Unable to open the first data file
InnoDB: Error in opening ./ibdata1
110203 10:44:59 InnoDB: Operating system error number 11 in a file operation.
InnoDB: Error number 11 means 'Resource temporarily unavailable'.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/operating-system-error-codes.html
InnoDB: Could not open or create data files.
InnoDB: If you tried to add new data files, and it failed here,
InnoDB: you should now edit innodb_data_file_path in my.cnf back
InnoDB: to what it was, and remove the new ibdata files InnoDB created
InnoDB: in this failed attempt. InnoDB only wrote those files full of
InnoDB: zeros, but did not yet use them in any way. But be careful: do not
InnoDB: remove old data files which contain your precious data!
110203 10:44:59 [ERROR] Plugin 'InnoDB' init function returned error.
110203 10:44:59 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
mysqld: Too many arguments (first extra is 'restart').
Use --verbose --help to get a list of available options
110203 10:44:59 [ERROR] Aborting

110203 10:44:59 [Warning] Forcing shutdown of 1 plugins
110203 10:44:59 [Note] mysqld: Shutdown complete

InnoDB: Error: tried to read 65536 bytes at offset 0 4804096.
InnoDB: Was only able to read 512.
InnoDB: Fatal error: cannot read from file. OS error number 17.
111008 12:45:30 InnoDB: Assertion failure in thread 3086124736 in file os/os0file.c line 2291
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
111008 12:45:30 - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 310227 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = (nil) thread_stack 0x30000
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

Then I tryed putting innodb_force_recovery= 1-6 into my.cnf.
From which only 6 helped server to start.

But could not connect to db anyway.

Left the thing a couple of hours at that state.

commented out innodb_force_recovery= 6 in my.cnf, restarted and now it works.