PDA

View Full Version : IE8 slideshow issue all other browsers ok



Gibson
Mar 22nd, 2011, 11:20 AM
Hi,

I have an Issue with a Javascript slideshow. If you see link below it is obvious :)

http://scriptdemo.co.uk/davidgray/alphanetdesign/updates/index.html

please can you advise? I only get the Issue in Internet Explorer 8

many thanks
Joe

Kor
Mar 22nd, 2011, 12:13 PM
You have several errors, CSS and javaScript. For instance: you have an argument of a function:

function swap(el){}

Which was not declared at all (or not passed), thus it is null.

Gibson
Mar 22nd, 2011, 12:32 PM
Hi,

Please can you advise a fix as I created the backbone but someone else insert the slideshow and it cocked everything up after that and I'm not familiar with Java that well.

Thanks alot
joe

Kor
Mar 22nd, 2011, 01:04 PM
You have there a code line:

swap(document.getElementById('first'))

But you have no element with the id="first"



I'm not familiar with Java that well.

In fact you know almost nothing, as long as you confound Java with JavaScript. Learn JavaScript or hire a professional to clean the codes, if you are not able to understand them.

Gibson
Mar 22nd, 2011, 02:43 PM
Hi!

Thanks alot for you advice :)

I have looked at what you said and if I remove that script it doesn't effect anything on the site.

What happened is I was asked to do an Accordian style Jquery menu and a slideshow (different one)

I completed it all ok and it worked fine and then I passed it on to the company that wanted it and they jiggered it all about and basically messed it up! So i'm looking at some of this stuff and think whhaaaaaat is going on haha.

I guess I'll have to keep looking

Thanks alot
joe