PDA

View Full Version : tabs don't display content



killthyspirit
Feb 11th, 2011, 06:18 PM
Hi,
I have created three tabs to display different content in each.

Although I can click and go to the specific tab, but except the first 1 the other two tabs don't display any content or html that I have.

Can anyone find any problem in the code?

I have attached just the html. please excuse the structure of the code as it needs to be that way.

thanks

Pyrrhic
Feb 11th, 2011, 06:58 PM
Try this




<div class="tabcontent">
<div>

<div class="tabcontent cushycms" id="content1" style="display:inline;"><div style="text-align: center">
<br /><br />

CONTENT1 HERE


</div>
</div>

<div class="tabcontent">
<div>

<div class="tabcontent cushycms" id="content2" style="display:none;"><div style="text-align: center">
<br /><br />

CONTENT2 HERE

</div>
</div>

<div class="tabcontent">
<div>
<div class="tabcontent cushycms" id="content3" style="display:none;"><div style="text-align: center">

Checkboxes

</div>
</div>

killthyspirit
Feb 19th, 2011, 01:11 PM
hi pyrrhic, would you tell me another quick thing-

in the same tabs code, I want to add a simple background to each tab (color or image) with mouseover, is there a way to achieve this? right now it is just plain text.

I tried using onmouseover but I have to do individually for each item. Is there way to do this for all tabs even if I have more than three. Please let me know how I can do this.

jmrker
Feb 19th, 2011, 03:47 PM
See: http://webinterfacetricks.com/

Specifically the "Tab View" section.

Pyrrhic
Apr 28th, 2011, 08:21 AM
nevermind