PDA

View Full Version : Internet Explorer image alignment problem. Please help.



WaterBottle
Jan 12th, 2011, 06:43 AM
Hi guys, I'm new here - I read the board but have never posted. I've been stuck on this issue for 2 days though and it's driving me crazy and I was hoping someone could possible take a look and help me figure out what i'm obviously missing!!!

I'm designing a personal website.

I like the way this looks now on Firefox and Safari, but when I view it on Internet Explorer the images on the right somehow get shifted down and it makes the page look all funny.

I just want it to look the same across all browsers and I don't understand why the images get shifted in IE. I have no idea what the problem could be and dreamweaver can't find any compatibility issues. If anyone could help I would appreciate it SO MUCH!!!

THANKS!

Excavator
Jan 12th, 2011, 10:02 AM
Hello Waterbottle,
You have some very basic errors in your markup that need to be fixed. Check your site with the validators... see the links about validation in my signature line below.


In IE, your first vspace placed anchor (resume) appears to start on the same level your ul stops. I'm not sure why.
I've never used hspace/vspace... it might be a little more predictable to absolutely position those buttons instead. That's how I would do it.

w3schools does say hspace/vspace on img is deprecated (http://www.w3schools.com/TAGS/att_img_vspace.asp) and should not be used.

WaterBottle
Jan 12th, 2011, 06:21 PM
Thanks so much!!!! That worked!!! Sorry for the stupid question in hindsight - I am pretty new to this, and I REALLY appreciate your help. I was working on this for hours and hours!

Thanks again!!!!

teedoff
Jan 12th, 2011, 07:20 PM
There are no stupid questions...especially when dealing with how IE might render a page. Never know what you'll get! lol