View Full Version : Forcing Unicode Character Set

05-22-2003, 04:36 PM
Good morning!

I've got a problem.

I've designed an ASP page that extracts text from a database and sends the information to a Flash movie. The problem is that when the text has international characters, Flash doesn't interpret the characters right.

I originally thought that this was a Flash problem, but it turns out that the ASP isn't sending the text in Unicode format.

I need to force ASP to use Unicode (encoded using either UTF-8 or UTF-16) or use a Unicode escape sequence to include any international character.

Is there an equivilent in ASP to the following PHP code:

myText = utf8_encode(myText)

If not, how do I force ASP to send the text correctly?

Please help!

Thanks in advance!!

05-23-2003, 03:56 PM
check this http://www.asp101.com/articles/flash/index.asp out.
values need to be in the querystring and need to use server.URLendcode

example with complete sourcecode at the botom. (Haven't tested it but it looks good)

05-23-2003, 05:05 PM
Yeah... my string is URL encoded, which makes this all the more perplexing.

If you go to the following URLs you'll see what I mean:

This is the ASP file that generates the string:


As you can see, it's URL encoded.

This is the result:


You'll notice that the ticker on the left-hand side is not displaying the international characters correctly.

I've tried everything to fix this problem. I tried using Flash's built-in unescape function and that doesn't work either. I've been on countless Flash support websites, and no one can help me.

This is driving me insane!!:confused:

05-24-2003, 01:42 AM
I'm not sure what you did, but it looks like it's working now to me... are you still having problems with this? :)

If you did solve it, please post your solution as well, it might help someone else! :)

05-24-2003, 10:09 AM
Indeed seems to work. Post it up here.

I noticed yesterday it showed a </html> and wanted to point it out (gotgot). I see you stripped of the html and just printed the text.

10-27-2003, 04:55 AM
I had similar problem (now solved):