PDA

View Full Version : Resolved Problem with Pictures not showing correctly in Opera and IE



Sephi
Jul 23rd, 2010, 05:37 PM
Hey,

check out my Fidgetr Plugin on the right side. It pulls pictures from Flickr. In Firefox it opens in a Lightbox just fine when you click on a picture. In IE and Opera the box loads, but it is very small. Hard to explain just check it out. Is there any explanation for that?

Strange thing is: from time to time it worked correctly in IE. What's up with that? I can't make out a rule.

Sephi
Jul 24th, 2010, 10:37 AM
Sorry, it's not resolved, was a mistake!

Sephi
Jul 26th, 2010, 09:27 AM
Not resolved. :(

abduraooft
Jul 26th, 2010, 09:34 AM
check out my Fidgetr Plugin on the right side. Right side of what?

Sephi
Jul 26th, 2010, 12:20 PM
The Widget area. It seems to work randomly. Sometimes it loads correctly, sometimes it zooms in to a tiny white area and doesn#t show the picture at all.

Sephi
Jul 26th, 2010, 02:17 PM
That's the script code, btw:
<script type="text/javascript">
var timeOutId = 0;
jQuery(document).ready(function() {
jQuery("#fidgetr_container_<?php echo $this->number; ?> .fidgetr_link > img:first-child[src]").parent().slimbox({}, function(el) {
return [el.firstChild.src.replace(/_[mts]\.(\w+)$/, ".$1"),
'<a href="' + el.href + '" target="_blank">'+el.title+' &rarr;</a>'];
});

jQuery("#fidgetr_container_<?php echo $this->number; ?> div").bind("mouseenter mouseleave", function() {
var comments = jQuery(this).find(".fidgetr_commentcontainer_grid" );
comments.toggle("fast");
});
});
</script>