View Full Version : Xampp Installation

06-01-2010, 02:01 PM
I wanted to install XAMPP for php and mysql. I downloaded XAMPP 1.7.3. I had saved in F: drive. But it is not running. When I run localhost, it displays page cannot be found. I have IIS and Asp files are working fine. Will it not be used on the same system. When I run Control panel for XAMPP, and run Apache and MySQL status busy is coming? Is there a problem in installation?

06-01-2010, 02:56 PM
But it is not running. When I run localhost, it displays page cannot be found. have you successfully run the xampp_start file before opening the localhost?

06-01-2010, 03:09 PM
Apache for XAMPP won't run if there is something else already using port 80. Most commonly are IM clients and other servers.

06-01-2010, 03:12 PM
So if I am already using IIS should I uninstall it ? Can we not use both ASP and PHP in the same system?

When I start the xampp_start.exe it displays starting 'xampp' and closes after a while..

06-01-2010, 03:22 PM
Can you open the xampp control panel? It will show you if apache is running. Also check to see in your task manager if apache is running there. You would have to configure IIS or Apache to use a different port.

06-02-2010, 11:37 AM
If I start Apache or MySQL in control panel I am getting Busy...
Apache service started
But I am not able to run php
Still the default is showing asp only..
Does anyone know how to change the port so that I can use both asp and Php

06-02-2010, 05:37 PM
The MMC snap in for IIS will let you change the port the web server is running on. And for apache you can edit the config files to change the port it uses.

Check this out: http://varunkrish.com/making-apachexampp-and-iis-work-together.html

06-04-2010, 07:41 AM
I tried installing WAMP. But when I run the software I am getting an error like this
An unhandled win32 exception occured in httpd.exe[3548]

and asking for debuggin in Visual Studio. I was getting the same error when I tried running iTunes also. Hence I thought the problem was something to do with my system, and hence have called the hardware person who said that a format is required..

Am I right in assuming there is system problem?

06-06-2010, 10:15 PM
Am I right in assuming there is system problem?
If this is the only issue you are having then probably not. Check the apache error log after you attempt to start it. It is pretty good at telling you the exact issue in the event it fails to start, as long as it's just failing to start and not crashing. If it is crashing check the windows error log as it might give you a clue to the issue.