View Full Version : freedns.afraid.org domain cloaking not working

04-26-2010, 06:12 PM
Hey wasn't exactly sure where to post this, but I am having a problem cloaking my afraid.org domain. I use a dynamic dns through dyndns.org, and forward the dynamic ip with afraid.org. The problem is that the cloak does not show the specific page. For example it shows domain.com when it should show domain.com/about.html. I DO NOT use the 'force dir root' option on afraid.org. Here is what I have listed on the web forward:

Redirect From: domain.org.org
Redirect To: http://domain.gotdns.com:8080 (cloak checked)
Page Title: (if cloaked): domain.org.org (force dir root NOT checked)

*I use port 8080 because port 80 is blocked by my isp. I also tried using a mod rewrite, but it just got stuck in this endless redirection loop. Any help would be greatly appreciated.


04-26-2010, 08:52 PM
Cloaking and showing a specific page when you go to the index of the site are two completely different things. Which exactly is your problem?

04-26-2010, 09:05 PM
The cloaking is the problem. No matter what page of the site your on, the url bar shows domain.com not domain.com/about.html or domain.com/whatever.html. Its acting as if I have the force dir root selected.

04-27-2010, 12:04 AM
As far as I know, (I've never used cloaking personally, btw), that is normal behaviour for the situation.

04-27-2010, 03:28 PM
is there any way to do it through a mod rewrite then? I have to use the port number in the dynamic dns domain which makes it pretty ugly. I would want to change:




Last time I tried the browser got stuck in a loop, each domain redirecting to the other.

04-28-2010, 12:57 PM
As far as I know, no. I may be incorrect, but I believe cloaking works by just loading your site in a frame. There's nowt you can do to workaround the title of that frame. If there was, the cloaking would be pretty pointless.