View Full Version : Compilation errors configuring Ruby 1.8.6 with ActiveTcl-8.5

04-23-2010, 10:47 PM

I am trying set up Tk for use in my 1.8.6 Ruby install.

I have installed ActiveTcl-8.5 and it is located at /opt/ActiveTcl-8.5

I configure Ruby with the following options:
% ./configure --with-tcl-dir=/opt/ActiveTcl-8.5 --with-tk-dir=/opt/ActiveTcl-8.5 --with-tcllib=tclstub8.5 --with-tklib=tkstub8.5 --enable-tcltk_stubs --enable-tcl-thread --enable-pthread

And then when I run make, I get the following errors:
/home/ruby-1.8.6/ext/tk/tcltklib.c:7850: undefined reference to `TkFindMenuReferences'
/home/ruby-1.8.6/ext/tk/tcltklib.c:7877: undefined reference to `TkEventuallyRecomputeMenu'
/home/ruby-1.8.6/ext/tk/tcltklib.c:7878: undefined reference to `TkEventuallyRedrawMenu'
collect2: ld returned 1 exit status
make[1]: *** [ruby] Error 1
make[1]: Leaving directory `/home/ruby-1.8.6'
make: *** [all] Error 2

I've tried Googling this problem, but nothing comes up, anybody out there have any ideas?