PDA

View Full Version : Ghost Image



enderwiggin7
Apr 21st, 2010, 07:26 PM
This contact page (http://theomgband.com/contact.html)'s code calls for the facebook logo after the contact information, but it doesn't show up. Any ideas on what's causing it to ghost?

skywalker2208
Apr 21st, 2010, 07:34 PM
If you are talking about why the image doesn't show up. It is because for the link tag you have visibility: hidden. Take a look



a {
color:#000000;
font-size:xx-small;
font-style:normal;
text-decoration:none;
visibility:hidden; /* This is hiding the image */
}

enderwiggin7
Apr 21st, 2010, 07:45 PM
This is what I hate about CSS -- it did that on it's own, I never set that. Rather, I guess its what I hate about Dreamweaver, because it added the CSS. So I removed the class from the image, but still not seeing it… :mad:

skywalker2208
Apr 21st, 2010, 07:50 PM
You don't need to remove the class. You need to go to your index.css file and find the code I posted and remove the visibility: hidden.

Might I suggest you learn how to code without dreamweaver design view. If you want to use dreamweaver then use code view. You will have a better understanding of what is going on and not have added code that dreamweaver tends to add.

enderwiggin7
Apr 21st, 2010, 07:54 PM
Yeah, definitely – I'm trying to learn. It just sucks that I bought this expensive software and then have to go and manually add everything to avoid Dreamweaver's quirks – there's got to be a better way.

I don't want to change that particular .css setting because I need it elsewhere – it's set that way on purpose. That image shouldn't be formatted like paragraph text on index.html, I just want it to indent properly to line up with the paragraph text on contact.html. Does that makes sense?

skywalker2208
Apr 21st, 2010, 08:19 PM
Yeah, definitely – I'm trying to learn. It just sucks that I bought this expensive software and then have to go and manually add everything to avoid Dreamweaver's quirks – there's got to be a better way.

I don't want to change that particular .css setting because I need it elsewhere – it's set that way on purpose. That image shouldn't be formatted like paragraph text on index.html, I just want it to indent properly to line up with the paragraph text on contact.html. Does that makes sense?

I am just pointing out what part of your code that is hiding the image. You pretty much have 3 options.

1. Leave it as is
2. Remove the code
3 Change it so you are not applying same code to all links. Pretty much use a class.