PDA

View Full Version : Submit button display issue in both FF & IE



greens85
Mar 9th, 2010, 11:17 AM
Hi,

My submit button doesn't seem to want to display correctly in either FF or IE. I have attached the HTML, CSS and some screen shots... anyone got any ideas on this one?


<form action="" method="post" class="right_aligned">
<label>Name:</label>
<input type="text" name="name" id="name"/>
<br/>
<label>Email:</label>
<input type="text" name="email" id="email"/>
<input type="submit" name="submit" id="submit" class="newssubmit"/>
</form>


.right_aligned {
height:10em;
line-height:1.2em;
}

.right_aligned label {
display:block;
float:left;
clear:left;
width:80px;
text-align:left;
font-weight:bold;
font-size:18px;
}

.right_aligned select, .right_aligned input {
height:20px;
font-size:16px;
border:1px solid #CCCCCC;
color:#000000;
}

.newssubmit {
}

Many thanks,

Greens85

JordanW
Mar 9th, 2010, 02:08 PM
I'm guessing your issue is the submit button text being too large for the submit button and thus being cut off at the bottom. Therefore, just make the submit elements height bigger:




.right_aligned {
height:10em;
line-height:1.2em;
}

.right_aligned label {
display:block;
float:left;
clear:left;
width:80px;
text-align:left;
font-weight:bold;
font-size:18px;
}
.right_aligned .newssubmit {
height:100px;
}

.right_aligned select, .right_aligned input {
height:20px;
font-size:16px;
border:1px solid #CCCCCC;
color:#000000;
}



~Jordan

greens85
Mar 9th, 2010, 05:49 PM
I'm guessing your issue is the submit button text being too large for the submit button and thus being cut off at the bottom. Therefore, just make the submit elements height bigger:




.right_aligned {
height:10em;
line-height:1.2em;
}

.right_aligned label {
display:block;
float:left;
clear:left;
width:80px;
text-align:left;
font-weight:bold;
font-size:18px;
}
.right_aligned .newssubmit {
height:100px;
}

.right_aligned select, .right_aligned input {
height:20px;
font-size:16px;
border:1px solid #CCCCCC;
color:#000000;
}



~Jordan

Hey Jordan,

Thanks for the reply...

seems to have done the trick