PDA

View Full Version : Submit button disappears when there's a textarea



jenius
Feb 4th, 2010, 06:50 AM
This is a huge amateur question, but for the life of me, I cannot figure out why this happens.

I have a nice little contact form I'm making for the site, and whenever I put in a submit button, nothing shows up. However, the second I remove the textarea, the button shows up. I really can't figure out why this is happening...

View Example Page Here (http://djjenius.com/testing/jenius/contact.html)

I realize that I have some pretty crazy css formatting going on in order to get the fields to align as I wanted them, and thought it might be that which was causing the button to get whacked out. But I also made a new page with no additional formatting - only two text fields and a textarea, and the same exact thing happened.

Help?! :confused: :confused:

View Basic Page w/o Formatting (http://djjenius.com/testing/jenius/testing.html)

HTML of basic page without additional formatting (still doesn't work)


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html>
<head>
<title>Form</title>
</head>
<body>
<form>
Name: <input type="text" name="name" id="name"/> <br /><br />
Email: <input type="text" name="email" id="email" /><br /> <br />
Message: <textarea rows="9" cols="29" id="textbox" />
<input type="submit" value="Submit" />
</form>
</body>
</html>


In addition, my markup is horrendously invalid for both the basic and complex forms, but not being familiar with making forms, I'm not sure exactly where my error is or what I could do to fix it while retaining the same appearance...

abduraooft
Feb 4th, 2010, 08:14 AM
Validator is your friend! See http://validator.w3.org/check?uri=http://djjenius.com/testing/jenius/contact.html

<textarea rows="9" cols="29" id="textbox" /> The closing tag of <textarea> should be </textarea>

jenius
Feb 4th, 2010, 08:29 AM
haha thank you, I tried adding this and it still did not work, unfortunately. Either way, after seeing the valdiator output I was convinced that I should probably just start over because everything was a disaster, and ended up with (hopefully) a much better result. I will post it here shortly :)