PDA

View Full Version : IE 8 images outside of cells when loading or needs refresh



Martins
Feb 1st, 2010, 02:34 PM
IE 8 images outside of cells when loading or needs refresh

As part of a webpage, I have a photo gallery made some while ago using a table with about 20 cells for the images. With IE8 the images are hanging partly (about 50%) outside of the cells until the page loads fully or in some cases until the page is refreshed. All other browsers and versions of IE are fine.

I have eliminated all javascript from the page. I am testing locally or on the Microsoft Development server, not online. I suspect the problem may be worse or exacerbated when there are other demands on system resources.

I would appreciate any suggestions.

Excavator
Feb 1st, 2010, 05:23 PM
Hello Martins,
We'll have to see some code to tell why it's not working. Since your problem concerns images a link to the test site would be best.

Martins
Feb 2nd, 2010, 03:12 PM
Excavator,

Thanks for the suggestion but my site is not uploaded yet. I don't think it's a coding problem, it validates and I have tried eliminating css and html line by line without much success. I am wondering if it is a browser performance issue?

harrierdh
Feb 2nd, 2010, 10:30 PM
If you don't have a link post your code with images. Don't use a zip file. Use the icons above. It could be just about anything. The first thing that comes to mind is that you have some conflicting CSS positioning versus your tables. It could just be your environment. Since you are running locally. Are you bringing up pages in actual browsers or a browser simulator inside Microsoft Development server?

Excavator
Feb 3rd, 2010, 02:53 AM
You will need to upload it sometime ... might as well do it if you expect to get much help.
We can guess all day but we're really not mind readers. Well, maybe abduroft is but certainly no-one else. The point is though, if we can't see what's making your images display wrong...we can't tell you what's making your images display wrong.

If you don't think it's a CSS/HTML issue, you are in the wrong forum.

Martins
Feb 3rd, 2010, 05:50 PM
harrierdh,

Thanks for your comment concerning conflicting css. I set the overall height
of the table in css, if I remove this the image loading problem is resolved. Obviously I missed this earlier.

I now have the problem that the table finds its own height, which varies by browser and does not fill the same space on the page The table has cellspacing, padding, borders etc.

I set the table height originally so that it would fill a specific number of pixels in the layout. It has not been a problem until IE8.

With regard to your question, I am using the actual IE8 browser, not a simulator.