PDA

View Full Version : browser not displaying correctly



orlando web
Jan 31st, 2010, 07:25 PM
I'm building this webpage for a client who only wants tables and I cannot get this page to view correctly in Firefox but it looks fine in IE & Chrome.

http://www.broadstonemedia.com/offer

If I adjust it to look fine in FF then it looks incorrect in Chrome & IE..

I have figured out that it is the size of the flash object that is causing one of the white lines to appear

the code is:

<td bgcolor="#000066" colspan="2" margin="0px">

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="446" height="259" style="padding="0px" margin="0px"
xcodebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0">
<param name="movie" value="http://eduplex.us/uploads/C1/Shack1Offer.swf" />
<param name="loop" value="false"/><param name="quality" value="high" />
<param name="wmode" value="transparent" />
<embed src="http://eduplex.us/uploads/C1/Shack1Offer.swf" width="446" height="259" wmode="transparent" quality="high" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

</td>

When I adjust the height to 254 px in height instead of 259px, it views fine in FF but it too short in IE & Chrome. 259px is the height the flash object is supposed to be.

I can't figure out why the 2nd horizontal white line is appearing

Anyone has fix ideas? It's pretty simple code but I'm not a tables guy, only CSS.

Thanks in advance

abduraooft
Feb 1st, 2010, 07:45 AM
I'm building this webpage for a client who only wants tables and I cannot get this page to view correctly in Firefox but it looks fine in IE & Chrome. Then, it might be worthless to expect cross browser support since using tables for layout is very bad (http://www.hotdesign.com/seybold/)!

drhowarddrfine
Feb 1st, 2010, 03:31 PM
The client, a religious organization, wants their web site laid out with tables? Strange.

mbaker
Feb 1st, 2010, 11:55 PM
Try making these changes:

change all 5 margin="0px" to margin="0"
change <td colspan="2">&nbsp;</td> to be <td colspan="2" height="38">&nbsp;</td>
change <td colspan="2" bgcolor="#000066"> to be <td colspan="2" bgcolor="#000066" height="259" width="446">
in both <object and <embed change height="259" to height="253"
change <td style="padding-top: 0px;" bgcolor="#000066" height="170" width="224"> to be <td style="padding-top: 0px;" bgcolor="#000066" height="181" width="224">

orlando web
Feb 2nd, 2010, 07:41 PM
Thanks Mbaker for taking the time effort to help me!! Worked perfectly.