View Full Version : C++ jGRASP MinGW program running help!

10-03-2009, 03:15 AM
Hi, I am using jGRASP with MinGW and when I run my program the window kills and I receive the error

"jGRASP wedge2 error: command "C:\.....\a.exe" does not exist."

I've searched everywhere and with no clear fix. I don't know the name of the .exe I need since jGRASP assumes that the executable is named a.exe unless the setting is changed which I don't know where that is either :confused:

Any suggestions?

Thanks in advance! :)

10-03-2009, 06:36 PM
If you use the default or MinGW compiler environments in jGRASP, then your program will be named "a.exe". Did you only compile, or "compile and link" (double green "plus" button on toolbar), or are you using a Makefile? Compiling only will not create an executable, so if you have a single-file project, use "compile and link". If you are using a Makefile with a different executable name than "a.exe", you will have to create your own compiler environment in jGRASP - you can start by copying the default one, and the changes you will need to make for a different executable name are fairly obvious.

10-04-2009, 12:00 AM
I was using just compile instead of "compile and link" even though I swear I remember trying it! :p ...oh well, it worked. Thank you thank you lbarowski!