View Full Version : Upgrading phpdev to php 4.3.1

04-04-2003, 10:17 PM
Ok some might know that I've been trying to upgrade phpdev for some time now but with no luck. I tried the phpdev upgrade exe but that doesn't work and I've read on the the help forums it doesn't seem to work for anybody. I came across a post on the phpdev forums which explains how to upgrade but I'm a little lost. I posted on those forums but nobody replied so I come here. :) Hopefully this is ok?

Anyhoo these were the instructions to upgrade the php to the latest version.

1. Download the PHP 4.3.1 zip package [5,853Kb] - 17 February 2003

2. Unzip it to a temporary folder

3. Copy php4ts.dll & php4ts.lib from the highest level folder into the SAPI folder

4. Copy or move everything into your exisitng phpdev 'php' folder (usually c:\phpdev\php)

5. Edit php.ini (I'm running XP and mine is located in C:\Windows) by doing the following:
Search for and comment out the following two lines by placing a semi-colon ';' at the beginning of the line:


I don't fully understand step 3. I searched for those files and the only place they're located are in the phpdev sapi folder. It says to copy them into the sapi folder but they're already there?

Has anybody upgraded ok or have any tips on how to do it?

04-05-2003, 02:54 AM
Hi whitty,

copy the entire new(downloaded) php folder over the top of the old C:\phpdev\php folder

make sure that php4ts.dll is in the /php/sapi/ folder (i.e. move/copy it there)

ignore the php.ini for now although the less extensions you have running the less can go wrong ;)

restart apache , I assume you are getting errors , please tell us what they are (also what version apache - did you upgrade to apache 2.0.44 ?)

if you get errors about zlib.dll - copy zlib.dll from (probably in /php/dlls/) to /php/sapi/zlib.dll

note that the /php/sapi/php4ts.dll is probably from the original phpdev download , the zip from php puts php4ts.dll in /php/ you will need to overwrite the phpdev version for the upgrade to work.

04-05-2003, 03:12 AM
Thanks for the response :)

When I try to copy the new php folder over top of the phpdev one I get the following error message:

cannot move EXTENSIONS: A file with the name you specified already exists. Specify a different filename.

I've tried twice now and its happened both times.

<edit> When I first get prompted to overwrite everything, I click yes to overwrite everything even if files already exist.
I then get the above error which cancels the copying.

04-05-2003, 05:33 AM
lol OK , you should have the option to overwrite ? unless PHP is apache/running and those files are in use ??

anyway , just rename your phpdev/php folder to php_old or whatever (dont delete yet) then copy the new php folder in place , move the php4ts.dll to sapi as above (possibly zlib as well) and restart apache ... I am gonna guess that you are on winME ?

04-05-2003, 05:36 AM
I'm on winxp.

I wasn't running either apache nor php and I wasn't given the chance to overwrite. Anyhoo don't know why I didn't think of what you just wrote. Kinda silly actually. Anyhoo I'll try it now and update on how it went.

04-05-2003, 06:31 AM
Alright I did what you said. I moved the new php folder into the phpdev one. I commented out the certain extensions in php.ini and when I went to restart apache (version 1.3.27) it gave me a while bunch of errors that it couldn't locate certain files. I just copied all the files it said it was missing from the old php folder into the new one. It was a few dlls including the whole dll folder.
Now it'll run fine but it still says php 4.2.3

Little help? lol :)