PDA

View Full Version : a hover intermittent in Firefox



Galceran
Feb 27th, 2009, 04:17 PM
CSS code:
a {
text-decoration : none;
}
a:link {
color : #900b09;
background-color : transparent;
font-weight : normal;
font-size : 1em;
}
a:visited {
color : #900b09;
background-color : transparent;
}
a:hover {
color : #4169e1;
background-color : transparent;
}
a:active {
color : #900b09;
background-color : transparent;
}

a:hover does work in IE but in Firefox it does not work on links near the top of the page. Halfway down it works. Some pages it works top to bottom.
On another website I have the a:hover in Firefox and works all the time, same CSS and XHTML coding.

Thanks

CSS and XHTML both validate with no errors.

abduraooft
Feb 27th, 2009, 04:26 PM
I can't see any such issue with the above CSS, when used with a simple link at my end. Could you post a link to your page?

Galceran
Feb 27th, 2009, 04:30 PM
http://www.tg11association.org/index.shtml

Link for Country Fire Authority does not show blue for hover.
Money Savings page. First two links do not show blue.

Thanks

Galceran
Feb 27th, 2009, 04:38 PM
Have to go out for couple of hours. Will come back.
Thanks
Gilbert

Excavator
Feb 27th, 2009, 04:41 PM
All blue for me, FF3 and IE7.
IE8 no blue on any link.

drhowarddrfine
Feb 27th, 2009, 04:41 PM
It works for me.

abduraooft
Feb 27th, 2009, 04:44 PM
Got it !
You have
#foot a:link, .content a:visited, .content a:active {/*style.css (line 318)*/
background-color:transparent;
color:#900B09;
font-size:1em;
font-weight:normal;
} in your CSS, and you might have visited that link in your FF, but not in IE :)
Am I right?

Galceran
Feb 27th, 2009, 08:14 PM
Well you are quite right of course. But deleting .content a:visited has different effects on hover. However I had it working on another site without problems. The W3C CSS site does show an example having the same sequence as mine. Visited has no effect on the hover after clicking their example link and returning to it. It still hovers in a different color.

You have taken the Footer portion which is also wrong, it should be

#foot a:link, .foot a:visited, .foot a:active {
color : #900B09;

Which set me thinking. I changed the code for links in the center column from

.content a:link, a:visited, a:active {
color : #900b09;
background-color : transparent;

to include the attribute .content for each one

.content a:link, .content a:visited, .content a:active {
color : #900b09;
background-color : transparent;

which solved it. But thank you for your input which gave me a fesh idea.

Gilbert