PDA

View Full Version : Flash in IE



Mattaut
Jan 22nd, 2009, 04:36 PM
First off, I am new to coding flash movies html. I made a flash movie in Macromedia Flash 8 and then made a webpage in Dreamweaver 8. The flash movie plays fine in FF and Safari, but not in IE. Tested it in IE on both Mac and PC. What do I need to do with my code to make it work in IE?
FYI-Its not currently needed for internet use, only going to be viewed on computers with access to the files.


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>WNBC</title>
<style type="text/css">
<!--
.style1 {
font-size: 48px;
color: #C6CBD9;
font-family: "Myriad Pro", "Myriad Pro Black Cond", "Myriad Bold", "Myriad BoldItalic", "Myriad Italic", "Myriad Pro Black", "Myriad Pro Black Cond It", "Myriad Pro Black It", "Myriad Pro Bold", "Myriad Pro Bold Cond", "Myriad Pro Bold Cond It", "Myriad Pro Bold It", "Myriad Pro Cond", Myriad;
font-weight: bold;
}
-->
</style></head>
<body bgcolor="#000000">
<!--url's used in the movie-->
<!--text used in the movie-->
<!-- saved from url=(0013)about:internet -->
<div align="center">
<p class="style1">News Channel 4</p>
<p>
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="640" height="515" id="WNBC" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="WNBC.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#000000" />
<embed src="files/WNBC.swf" width="640" height="515" autostart="false" align="middle" quality="high" bgcolor="#000000" name="WNBC" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>
</p>
</div>
</body>
</html>




I ran it through the markup validation thing I found on this forum and it still doesn't work in IE. Here is the code it gave me-

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta name="generator" content="HTML Tidy for Linux (vers 1 September 2005), see www.w3.org" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>WNBC</title>

<style type="text/css">
/*<![CDATA[*/
<!--
.style1 {
font-size: 48px;
color: #C6CBD9;
font-family: "Myriad Pro", "Myriad Pro Black Cond", "Myriad Bold", "Myriad BoldItalic", "Myriad Italic", "Myriad Pro Black", "Myriad Pro Black Cond It", "Myriad Pro Black It", "Myriad Pro Bold", "Myriad Pro Bold Cond", "Myriad Pro Bold Cond It", "Myriad Pro Bold It", "Myriad Pro Cond", Myriad;
font-weight: bold;
}
-->
/*]]>*/
</style>

<style type="text/css">
/*<![CDATA[*/
body {
background-color: #000000;
}
div.c1 {text-align: center}
/*]]>*/
</style>
</head>
<body>
<!--url's used in the movie-->
<!--text used in the movie-->
<!-- saved from url=(0013)about:internet -->
<div class="c1">
<p class="style1">News Channel 4</p>
<p><object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="640" height="515" id="WNBC" align="middle"><param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="WNBC.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#000000" />
<embed src="files/WNBC.swf" width="640" height="515" autostart="false" align="middle" quality="high" bgcolor="#000000" name="WNBC" allowscriptaccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></object></p>
</div>
</body>
</html>



Please, I need this done very soon(in a couple hours). Hopefully someone will read this. Thanks!

abduraooft
Jan 22nd, 2009, 04:39 PM
[...]<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="WNBC.swf"/>
<param name="quality" value="high" />
<param name="bgcolor" value="#000000" />
<embed src="files/WNBC.swf" width="640" height="515" autostart="false" align="middle" quality="high"[...]
Any clues?
btw, I'd recommend the use of swf-object (http://code.google.com/p/swfobject/) to embed a flash movie in webpage.

PS: welcome to CF!

Mattaut
Jan 22nd, 2009, 04:54 PM
omg, didn't think it was that simple. Weird how it works in FF and safari though, too bad IE is the default browser for PCs :(