PDA

View Full Version : Resolved Please help...site looks different in Firefox, IE



wildviper
Jan 13th, 2009, 09:23 PM
Hi All,

I have been searching and making changes to my CSS and HTML file from this forum. But now I am stuck.

My site looks good(work still needs) on when pulled from localhost(my computer)..but when it goes online, one of the menu tabs doesn't show up.

There should be About Us, What We Do, Gallery and Questions. The Gallery tab doesn't show up. I have looked and uploaded the jpeg file numerous times. No luck. This happens in both IE 7 and Firefox 3.0. I haven't even tested others yet.

What gives here? Here is the url: http://www.fotomango.com/redesign/aboutus.html

I am attaching the style2.css file.

Both files validates properly.

Also, the text is coming all weird spacing. Anyone know why?

Thanx for any help.

Excavator
Jan 13th, 2009, 10:03 PM
Hello wildviper,
In your markup, gallery.jpg has all small caps. On your server, Gallery.jpg is capitalized... makes a difference on your server but not when your testing locally on your computer.
One reason for making EVERYTHING small caps.

I'm not sure what you mean by "text is coming all weird spacing" - it looks the same on FF3 and IE8 here.

twodayslate
Jan 13th, 2009, 10:03 PM
I don't like the double period.
http://img407.imageshack.us/img407/7338/screenshot2ok6.png

edit://not fast enough. Still, don't like double periods though.
This might help you understand any text issues: http://www.learn-css-tutorial.com/CssText.cfm

Excavator
Jan 13th, 2009, 10:11 PM
The .. is doing what it's supposed to. You'll have more trouble from the ' marks, should be more like this:
background: url(../images/Gallery.jpg) top center no-repeat;

Excavator
Jan 13th, 2009, 10:34 PM
Just to clarify, each ../ takes you up one directory.

.html at http://www.fotomango.com/redesign/aboutus.html
.css at http://www.fotomango.com/redesign/scripts/style2.css
img at http://www.fotomango.com/redesign/images/background.jpg
shortcut ../images/background.jpg


If your path was longer, like this -
img at http://www.fotomango.com/more/path/redesign/images/background.jpg
your image would be at ../../../images/background.jpg

twodayslate
Jan 13th, 2009, 11:25 PM
Still don't like the periods. Just a pet peeve I guess :p

wildviper
Jan 14th, 2009, 02:10 AM
lol about the ../ . I had to put that in because for some odd reason, it would not pick up the images dir or the scripts dir. like "/images/background.jpg".

Also, I just "renamed" the file to lower "g" and it works! Thank you so much for that. I must have spent close two hours trying to figure this little thing. Holy Cow!!! can't believe it is that simple!

Also, regarding the text, it was more the spacing. Not sure why the h2 and h3 text is coming so close to the regular "p" element text. I thought those were block elements and had a line above and below it. Anyways, I fixed that with adding line-height and also some <br />s.

I have also taken off the ' from the images.

Thank you again!