View Full Version : PHP, Apache and Windows

02-24-2003, 04:41 PM
Ok.... how to explain, how to explain...

My web-server runs Apache 1.3.26 on Linux, my test/personal server runs 2.0.39 on Windows. I use an edited version of http://evolt.org/article/Making_clean_URLs_with_Apache_and_PHP/18/22880/index.html to include files dynamically using .htaccess to make extensionless files act as PHP files.

For example e8o.com/artists/50_cent includes e8o.com/artistfiles/50_cent.htm and so on.

The problem is I can't get this little trick to work on my personal server so I've had to set up a *.php?p=filelocation/filename.htm to test pages locally instead.

My question is, does anybody know how to make the .htaccess trick work on my local version of apache?

I'm sorry, I can't explain it very well, I'll try again if you don't understand me! :o

02-24-2003, 05:06 PM
I am assuming you are using the force-type directive ? ...

well assuming .htaccess works at all on your apache version and that directory is configured to allow .htaccess then it could just be that apache /php4 filter is partly broken, I know the normal apache lookback feature did not work on several early versions.

maybe grab 2.0.44 as its the stablest with PHP so far , or better still just use 1.3.27 , there is nothing yet in apache2 that is of a major benefit on win32 .. i.e its not really finished ;)

but check your permissions in the httpd.conf first as thats likely where the problem is , try setting

<Directory /path/to/dir>
AllowOverride All

in httpd.conf then restart and try htaccess again, though I would use some more specific options if indeed thats the problem.

02-24-2003, 05:27 PM
Hi, thanks for your reply.

Yep I'm using the forcetype directive.

I'm not really very used to using Apache (was with IIS and before that PWS) so I used a precompiled PHP, Mysql, Apache package.

I've been using it for a month or so now and have played in the configuration files so have now decided to go and install everything, indivually, myself as a lot of the settings were getting on my nerves.

I'll let you know how it goes and if I can sort the problem out this way :)