View Full Version : Selinux Enable Failed

11-03-2008, 08:46 AM
Currently I have using RHEL4 Update 3 Linux and CentOS 4.4 Linux and I have disabled selinux during Kick Start Installation and now i want to enable selinux to both the machines

I have tried to enable the selinux using GUI tools system-config-securitylevel->selinux->Enabled (Modification Requires Reboot)
After reboot I have executed the getseboll command
i am getting the following message
getsebool: SELinux is disabled

I have executed following command to enable the selinux
setenforce 1
but i am getting the following message only
setenforce: SELinux is disabled

I have verified selinux rpm are installed or not
rpm -qa | grep -i -e selinux

I don't know what is the problem or i have done wrongly
Can any one help me or guide me to enable the selinux in MY PCs
Thank in Advance


11-03-2008, 12:03 PM
This isn't really a server side language issue, more of a computer / pc discussion.
Lessee, have you checked the /etc/selinux/config file to see if its still sitting at disabled? Oh, I should mention that my (broken) linux box is Fedora, but I think its still the same.
If its currently set to disabled, you'll need to activate it by changing it to... enforcing or enforced I think it is? The documentation in the file should tell you what it is (or you may need to google it up).
Don't trust the linux gui for anything. I remember trying to add a user once through it and it jammed up the interface. I was right displeased. Moreso when I found out it was a consistent problem. No big deal though, its 100000x faster to do it from the command line anyway :P

11-06-2008, 07:27 AM
Dear All,
I have changed my selinux configuration manually to enforcing, and i have rebooted my pc.
After boot-up i am getting the same status "selinux disabled"
getsebool: SELinux is disabled

Please verify my selinux configuration details below
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - SELinux is fully disabled.
# SELINUXTYPE= type of policy in use. Possible values are:
# targeted - Only targeted network daemons are protected.
# strict - Full SELinux protection.


11-06-2008, 09:13 AM
I found this like for you, looks like it may help:

Sounds like its having issues with either a broken symlink to the /etc/selinux/config file or its the labeling problem for selinux.
In the case of the latter, I would recommend you set you're selinux into permissive mode before running an autolabel. Apparently you can really jam things up if something goes wrong otherwise.

Hope that helps, without being able to perform any trials myself I don't think I can give you more advice; perhaps a linux expert on the forum here could pick up from this point.