View Full Version : Flash won't display on page...HELP!

03-04-2008, 02:22 PM
I'm trying to put a simple flash slideshow on a mostly html page (constructed via php). The swf plays fine locally, plays fine if I load it directly in a browser, but not on a web page.

Would someone mind having a look at my code and see if perhaps I am missing something.

I very rarely use flash at all. So, it's very possible I am overlooking something that's quite trivial to a flash pro.

Here's a mock webpage:

The flash should be over the shiny green buttons on the right.

Here's a direct link to the swf:

I'm using Dreamweaver which automatically places the call to the 'AC_RunActiveContent.js' file. Which I'm assuming does some browser sniffing or something. Haven't analyzed that code.

Any ideas?


For convenience sake...

The embed/odject code:

<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','160','height','124','title','Slideshow','src','/scripts/slideshow/final','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','/scripts/slideshow/final' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="160" height="124" title="Slideshow">
<param name="movie" value="/scripts/slideshow/final.swf" />
<param name="quality" value="high" />
<embed src="/scripts/slideshow/final.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="160" height="124"></embed>

and the call to the aforementioned DW script:

<script src="/scripts/AC_RunActiveContent.js" type="text/javascript"></script>

03-04-2008, 05:04 PM
I've never liked Adobe's script for embedding flash. I recommend using http://blog.deconcept.com/swfobject/

I'm pretty sure adobe's script is causing the problem.

03-04-2008, 05:42 PM
I had run across that while searching for a fix. I'll give that a shot tonight and see what happens.


03-05-2008, 12:29 AM

Check your .swf path. I had the same problem and when I moved the .swf out of my image folder to the main folder the menu showed up.

(If the deconcept thing works could you let me know?)


03-05-2008, 02:51 AM
Checked the path, checked it again. Moved the file, changed the path, redid the code using several methods. They all do the same thing. Nothing.

The SWFObject thing didn't work either.

I've even tried creating an absolutely blank html file and tried inserting it. Nothing.

Good grief. I tell ya what. I never expected this tiny portion of this site design to be such a pain!

03-05-2008, 03:11 AM
Ugh...finally got it to work.

I kept messing with it, trying different things and all of a sudden it worked. I tried so many things, I'm not sure what exactly I did that fixed it!

Now the only problem is that the slideshow is pushing the images I fed it to the right 1 pixel. Makes the graphic look kinda crappy.
After all that and I may end up going with a javascript slideshow! You gotta love that!

03-05-2008, 03:25 AM
Figured out the problem...
turns out it was the flash file's fault...sorta.

The slideshow I'm using uses an xml file to index the images to use.
Well, that file HAS to be in the root of the site in order to work. I can place the images and the swf anywhere else, even in a folder other than where the xml is and it works fine. If I move that xml file into a folder...it stops dead.

So, there ya go!

Oh, and it's working now with the original adobe js file. I'm assuming the SWFObject thing would work just fine too.

(Still have the 1 pixel issue though. Cripes)

03-05-2008, 07:51 AM
That means that the xml file is linked to the root of your site only. Once the xml is loaded it doesn't matter where the images are that it is linked, because that is inside the xml. So the flash file must be coded to expect it to be there.

I would also suggest using SWFObject, because the defaults are annoying and sometimes more problematic.

03-05-2008, 11:53 PM
Yep, exactly. Like I said, it works fine now, but I ended up having to scrap the flash route since it jacks up the image with that stupid pixel shift crap. As long as flash has been around, you'd think they'd have fixed that junk by now.

Oh well. Thank you all for your help anyway! :)