PDA

View Full Version : links disappearing



ds67
Jun 21st, 2007, 03:18 AM
Hello to all:

I did a search for this topic and found a few answers. However, non of them seemed to coincide with my situation (maybe they did and I just didn't understand).

Anyway, my problem is that I have embedded flash link buttons with a drop down menu action that's used in javascript. FF shows the links as I want them but in IE, when the last link to be 'mouseout', the link disappears.

Here is the page you can find what I'm talking about and below it is the coding I've used. Am I missing something?

http://danspainting.com/index44.html

==================================



startList = function() {
if (document.all&&document.getElementById) {
navRoot = document.getElementById("nav");
for (i=0; i<navRoot.childNodes.length; i++) {
node = navRoot.childNodes[i];
if (node.nodeName=="LI") {
node.onmouseover=function() {
this.className+=" over";
}
node.onmouseout=function() {
this.className=this.className.replace(" over", "");
}
}
}
}
}
window.onload=startList;


Also, is there a way to 'activate' these button controls? Everytime the page is loaded, all flash objects have a box around it saying to 'click to activate and use this control.'

Thanks so much. Sorry if this seems overly simple but I'm very new to javascript and trying to learn.

_Aerospace_Eng_
Jun 21st, 2007, 03:26 AM
I'm not experiencing the issues you are mentioning except for the click to activate thing. This is normal and its due to EOLAS. To get around it you must use javascript to embed your flash. I recommend SWFObject (http://blog.deconcept.com/swfobject/).

TBH I think you went a little overkill on the flash. NOT everything needs to be done in flash. Most if not all of what you have can be done with html/css/javascript.

ds67
Jun 22nd, 2007, 12:37 AM
I read and tried every combination to the swfobject i could think of. Now, nothing at all comes up. What am i doing wrong??

here is the page with the swfobject...

http://www.danspainting.com/flash.html

Here is the look of the page i'm trying to achieve (without the 'click to activate controls') using IE.

I think I'm more confused than ever. Help...

ds67
Jun 22nd, 2007, 12:45 AM
Scratch the last post. I figured out what was wrong. Too embarrassing to mention. Thanks for the help.