PDA

View Full Version : Problems with validating my website !



bilzone
Mar 14th, 2007, 10:05 PM
I try to validate my website to looks more professional but i still have 1 error where i don`t know what i do to remediate it.
This is :
- document type does not allow element "FORM" here; missing one of "APPLET", "OBJECT", "MAP", "IFRAME" start-tag.
And my website is www.softmrm.com
Hope to help me. Thx in advance.

VIPStephan
Mar 15th, 2007, 12:47 AM
You don't have one, you have lots of errors that the W3C validator isn't even showing (but Dreamweaver does!).


You can't have an ID in a script tag.
You didn't close your container div.
You didn't close several anchors.
You used a lot of unencrypted ampersands. The correct way to write an ampersand in HTML is &.
You are using deprecated elements like <font> and <center>.
You have no <html> starting tag.


If you want your code to look really professional use a strict doctype, don't use tables (I don't see anything on the index page that would justify the use of a table) and avoid presentational markup like <b>.

As to the error you are addressing above that's probably because a form can't be within a <b> element.

bilzone
Mar 15th, 2007, 12:52 AM
You don't have one, you have lots of errors that the W3C validator isn't even showing (but Dreamweaver does!).


You can't have an ID in a script tag.
You didn't close your container div.
You didn't close several anchors.
You used a lot of unencrypted ampersands. The correct way to write an ampersand in HTML is &amp;.
You are using deprecated elements like <font> and <center>.


If you want your code to look really professional use a strict doctype, don't use tables (I don't see anything on the index page that would justify the use of a table) and avoid presentational markup like <b>.

As to the error you are addressing above that's probably because a form can't be within a <b> element.

Thx a lot for your answer.i will try to remediate that errors and use dream to validate it...hope to resolve that...but where i have errors with ampersand is links generates by php and i don`t know how remediate it. Soon i remediate that i post there...thx and hope to help me..best regards