Hello,

I'm using Oracle's WebCenter 11g to grab data from a SOAP web service. The method and WSDL we are using has been proven effective using Cast Iron and another free program (SOAP UI), but when we make the same method call in WC the return body is wrapped in some garbage that looks a lot like a file or packet header.

My question for you is - whether or not you have any experience with Web Center have you ever encountered anything like this before? If so how did you resolve it? Any advice or suggestions are welcome - I have already done the obvious things, such as contact Oracle, post on their forums, and search the web tirelessly for an answer.

You're my last hope, obi wan kenobi.

Example:

Code:

Code:
------=_Part_43_450096191.1322605979830
Content-Type: application/xop+xml;charset=UTF-8;type="application/soap+xml"
Content-Transfer-Encoding: 8bit
Content-ID: <ffc52b167534468db5a9b212dba929dc>

<?xml version="1.0" encoding="UTF-8" ?>

<soapenv:Envelope xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope">
<soapenv:Body>
<ns1:getUDRDataResponse xmlns:ns1="http://general.service.webservices.xxxx.com">
<ns1:return ns1:type="com.skire.webservices.util.xml.XMLObject">
<ax21:statusCode xmlns:ax21="http://xml.util.webservices.xxxx.com/xsd">
200
</ax21:statusCode>
<ax21:xmlcontents xmlns:ax21="http://xml.util.webservices.xxxx.com/xsd">
&lt ;?xml version="1.0" encoding="UTF-8"?&gt ;
&lt;report&gt;
* &lt;report_header&gt;*
* &lt;c1&gt;Name&lt;/c1&gt;*
* &lt;c2&gt;Company Name&lt;/c2&gt;*
* &lt;c3&gt;Address 1&lt;/c3&gt;*
* &lt;c4&gt;Address 2&lt;/c4&gt;*
* &lt;c5&gt;Address 3&lt;/c5&gt;*
* &lt;c6&gt;City&lt;/c6&gt;*
* &lt;c7&gt;State&lt;/c7&gt;*
* &lt;c8&gt;Work Phone&lt;/c8&gt;*
* &lt;c9&gt;Zip / Postal Code&lt;/c9&gt;*
* &lt;/report_header&gt;*
..
..
..
      
------=_Part_43_450096191.1322605979830--
Many thanks,
Sethwb