Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 13 of 13

Thread: Site Review !!

  1. #1
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Site Review !!

    Hi there people !!

    Hi everyone I've got this site here I would like reviewing. It is a very simple site, with little graphics because this is what the client wanted. I just want some honest opinions, possible improvements etc ??

    Thanks
    Last edited by wap3; 12-07-2002 at 02:23 PM.

  • #2
    Regular Coder
    Join Date
    Jun 2002
    Posts
    262
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Feedback

    Hi.

    I'd change the colour of the menu text from blue to perhaps bold white.

    I'd change the colour of the copyright text too to match. Say bold white.

    I'd fix the grey cells on the left to either match the main body of the page of move the text to fit in nicely.

    I'd fix the cgi script for the contact us form - Get this error, Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@universaltools.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Besides that little lot is a good job. Fits nicely on 1024*768 screen although 800*600 will mean some scrolling, infact, quite a bit but hey!
    Therapy is expensive, popping bubble wrap is cheap, you choose.

  • #3
    Senior Coder Mhtml's Avatar
    Join Date
    Jun 2002
    Location
    Sydney, Australia
    Posts
    3,531
    Thanks
    0
    Thanked 1 Time in 1 Post
    Works fine for me though I think that you should change the color of the navigation links, they are a bit hard to see.

    I mean yes when you mouseover they are fine but users I'm sure would like to see clearer where the menu is as some people may have the brightness down low on the there computer or have bad eyesight so I think changing the colors is a good idea.

    But apart from that it is quite nice.
    Omnis mico antequam dominus Spookster!

  • #4
    Regular Coder
    Join Date
    Jun 2002
    Location
    Louisville, KY
    Posts
    279
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Looks pretty good. Just a couple suggestions:

    The black copyright text doesn't show up well on the blue background. Neither do the blue links at the top (until you mouseover them).

    The left grey part doesn't go all the way to the bottom. That's ok, but it looks a little awkward that there is also a white line through your name.



    Hope this helps. Looks good.

  • #5
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hmmmmm

    Thanks guys. All the bits you pointed out like the menu colour etc where supposed to show up as white. But I was fiddling with the style sheet and forgot to change its name back.

    Anyway it should show up properly now with white text etc ?? Does it ??

    oops

    The feedback form is not connected properly yet, ignore that for a minute.

    Does the left hand grey border reach down to the bottom now as it should of to start with ??

    Thanks

  • #6
    Regular Coder
    Join Date
    Jun 2002
    Posts
    262
    Thanks
    0
    Thanked 0 Times in 0 Posts

    the man from delmonte

    Say's Yes... Spot on mate
    Therapy is expensive, popping bubble wrap is cheap, you choose.

  • #7
    Senior Coder Nightfire's Avatar
    Join Date
    Jun 2002
    Posts
    4,266
    Thanks
    6
    Thanked 48 Times in 48 Posts
    Only one thing I don't like is that the nav links increase in size when you hover over them. The rest loks good to me

  • #8
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, thanks for the comments eveyone, keep them coming if you feel like it !!


    I've a favour to ask now, can some people test the quotation form on the site to see if it functions properly now.

    1.) Leaving fields blank or giving an invalid e-mail address should direct to an error page

    2.) If all fields are present and correct, it re-directs to a success page, which shows what you entered

    3.) A email should be sent to the email address you supplied (an autoresponder) if succesful

    Can you please tell me if these things happened ??

    Thanks

  • #9
    Regular Coder
    Join Date
    Sep 2002
    Location
    Burlington, VT
    Posts
    125
    Thanks
    0
    Thanked 0 Times in 0 Posts
    there's an error with your menu rollovers that is showing Opera 6.05...
    they roll on but don't roll off.



    may want to consider using another method or tweeking your code.

    nice site though.
    "The focused mind can pierce through stone."
    - Japanese Maxim

  • #10
    Regular Coder
    Join Date
    Jun 2002
    Posts
    262
    Thanks
    0
    Thanked 0 Times in 0 Posts

    quotation form

    It works a treat. I like the summary page too for correct forms.

    One thing, why not have the validation on the form page. That way, when submit happens and there is an error the client does not need to go back and you can specify which fields need to be completed with either a popup box or an image or something cool like that.

    Otherwise, cool..
    Therapy is expensive, popping bubble wrap is cheap, you choose.

  • #11
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Dauvm: Thanks for that I will have a look at my code and post back when I think I've got is sorted, so you or someone else can check it works in opera.

    Tommyspone: Got your e-mail glad it works. I take it you didin't get the e-mail autoresponder because of the e-mail address you gave ??

    Can you or somebody else enter your e-mail address and tell me if you get this autoresponder ??

    Thanks

  • #12
    Regular Coder
    Join Date
    Aug 2002
    Location
    UK
    Posts
    324
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, so I have had a fiddle with the menu script to try and sort out the problem dauvm pointed out.

    So can dauvm or someone else with opera 6 take a look and see if it works now ??

    Thanks guys

  • #13
    Regular Coder
    Join Date
    Sep 2002
    Location
    Burlington, VT
    Posts
    125
    Thanks
    0
    Thanked 0 Times in 0 Posts

    opera

    Hey wap3, still messed up in opera.

    maybe instead of using rollovers you can use css.

    a.menu:hover {color: #fff; text-decoration: underline; background: lightblue}

    <a class="menu" href="here.html">home</a>
    "The focused mind can pierce through stone."
    - Japanese Maxim


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •