Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 9 of 9
  1. #1
    New to the CF scene
    Join Date
    Sep 2011
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Site slow to load initially

    Hey guys and gals,

    I'm running a wordpress site, while the site run's ok, generally, it seems slow to load for new users, I'm running wp cache in the background and once your on it and browsing it's fine.

    It's not a huge issue, but if anybody have a few mins to take a look, and maybe let me know how I can investigate where this slowness is coming from.

    Dave..

    http://www.irelandscoarsefishing.com
    Last edited by VIPStephan; 09-14-2011 at 02:38 PM. Reason: removed link (backlink spamming suspected)

  • #2
    New to the CF scene
    Join Date
    Sep 2011
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    just a quick thought - have you set this site up in google webmaster tools? If so there is a section where you can see google's take on whether the site is slow to load - this will have an impact for seo purposes. if it says that it is slow in webmaster tools then you need to do something about it.

  • #3
    Regular Coder
    Join Date
    Jun 2002
    Location
    Flint, Michigan, USA
    Posts
    624
    Thanks
    1
    Thanked 20 Times in 20 Posts
    You might wish to check this list of your coding errors: http://validator.w3.org/check?charse...sefishing.com/

  • #4
    New to the CF scene
    Join Date
    Sep 2011
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by johntt View Post
    just a quick thought - have you set this site up in google webmaster tools? If so there is a section where you can see google's take on whether the site is slow to load - this will have an impact for seo purposes. if it says that it is slow in webmaster tools then you need to do something about it.
    Yup, I have it in G's webaster tool's altho it's never suggested to me that's it's slow and effecting SEO, Altho i know for sure something's slowing it down, but it's some even before it starts to load the code ..

    Quote Originally Posted by jalarie View Post
    You might wish to check this list of your coding errors: http://validator.w3.org/check?charse...sefishing.com/
    Weirdly enough I just checked this, and it says the code is ok ?

  • #5
    Senior Coder
    Join Date
    Jul 2009
    Location
    South Yorkshire, England
    Posts
    2,318
    Thanks
    6
    Thanked 304 Times in 303 Posts
    Optimise the content of your site. If the first load is slow with subsequent loads being okay, that suggests poorly optimised content, (images, scripts and the like).

  • #6
    New to the CF scene
    Join Date
    Sep 2011
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by MattF View Post
    Optimise the content of your site. If the first load is slow with subsequent loads being okay, that suggests poorly optimised content, (images, scripts and the like).


    Well,

    I had kinda hoped it was optomised as is, i'm running wordpress, and have the site set up with a cache plugin, however the show down seems to come even before the site actually starts to load any resources ..

    As if it's having trouble resolving the name = ip maybe ....

  • #7
    New Coder
    Join Date
    Oct 2011
    Posts
    37
    Thanks
    4
    Thanked 4 Times in 3 Posts
    I have a feeling that your host is overloading there servers. If your buying quality hosting then id look into changing the wordpress theme and also using a compression plugin.

    ps. this has happened to me in the past and once i changed my host it was no longer a problem.

  • Users who have thanked RonnieC for this post:

    irelandscoarse (10-22-2011)

  • #8
    New to the CF scene
    Join Date
    Sep 2011
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by RonnieC View Post
    I have a feeling that your host is overloading there servers. If your buying quality hosting then id look into changing the wordpress theme and also using a compression plugin.

    ps. this has happened to me in the past and once i changed my host it was no longer a problem.

    I think you might actually be on to something ronnie, i'm on shared hosting, but purchased a VM, from them, got it configured, but it onlt has 128 meg of memory, it was usless, couldn't even run my-sql php, and wordpress ...

    time to look at alternative hosting

  • #9
    New Coder
    Join Date
    Oct 2011
    Posts
    37
    Thanks
    4
    Thanked 4 Times in 3 Posts
    I use mddhosting.com and they are amazing. Super fast, and great service.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •