You can just as easily use
window.onload = init;
window.attachEvent( "onload", init );
window.addEventListener( "load", init, false );
There is a practical difference in terms of usability. Randomly named varaibles and functions make a script sematically useless and difficult to read. But no, the size of the variable name should have no noticeable effect.
Personally, I think it's easier to teach a user how to populate an array and initialize a function than to walk them through a process of creating options/values from an absurdly large amount of global variables and commenting. Even still, as I mentioned before, a wizard could easily be created to provide the small amout of code required.