Originally Posted by noobatjavascrip
When I have time I am going to opt out of the bezier curve methodology and just use straight lines to make the hole. Im thinking maybe because of using lineTo() and bezierCurveTo() that it might be causing some confusion. Also i will change the name of my function
I would consider splitting larger, regular, regions into a couple of rectangles and triangles. This will make it easier to build in stages, and to also modify (separately) later.