So I'm pretty new to Ruby (maintaining an environment, not the language), and I've been having the following problem:

I'm looking to add an FFT library to my install of Ruby 1.8.6 on a Windows Vista machine. Installing my desired FFT library seems like it should be easy enough, considering there are a few FFTW3 wrappers for NArray floating around and there is an FFTW3 gem in the RubyForge repository.

The problem I am having is that no matter which FFTW3 library I try to install, or how I try to install it (either using 'gem install FFTW3' or 'ruby extconf.rb' with appropriate options or by praying to the Old Ones), it comes up with the error:

checking for narray.h... no
*** extconf.rb failed ***

. . . and I don't get it: NArray is installed and works just fine, narray.h is where it should be with the rest of the NArray source files, and . . . guh. I've even tried copying narray.h and all other NArray files everywhere and it just won't see it.

There's probably something I'm missing; I'm a little lacking in the programming-environment-maintenance department, but any help would be greatly appreciated.

Thanks