Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Aug 2006
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    login problem on index page and sub pages

    Hello, my name is john rucker and i have recently paid for some php and mysql coding done by a freelancer. Well he decided to leave me a half-completed job. After paying him fully.

    i understand that i made a un-wise decision getting a freelancer, but he is really talented, but didnt care about finishing my site.

    Well i have on my site a login box and password box which when entering your phpbb forums username and password, it logs you into the index page and says "Welcome Username!" and next to that, "Logout" this was placed right where the login box is after u login in. This is how it was before, and worked perfectly.

    Only problem was if u wanted to just login on via the forum, after logging in, it would re-direct you to the index page, and if an admin wanted to login to the forums admin control panel, he would have to do the above, and ALSO then it would re-ask your password for admin authorization and when entered again, bring you back to the index page a second time. So he said he was gonna look into it about a month and a half ago. Well he must have edited something incorrectly because now when u login via the index page, nothing happens, it simply refreshes with the login boxes still there.

    my forum works 100% correctly, so i know it gotta be this guys coding!

    i have attatched my header.php, index.php

    my index pade, www.dishonor-elite.com

    username:Test
    password:Test
    ^
    forum login as well

    has anyone had this problem in the past? or any possible solutions?
    very thankful for everyones help here!
    Attached Files Attached Files

  • #2
    Regular Coder
    Join Date
    Aug 2006
    Location
    UK, London, Dartford
    Posts
    221
    Thanks
    3
    Thanked 14 Times in 14 Posts
    Make sure, your page is sending the information to the forum login page.

  • #3
    New to the CF scene
    Join Date
    Aug 2006
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    what section of the code is that?

    im new to php, but can do html

  • #4
    Regular Coder
    Join Date
    Aug 2006
    Location
    UK, London, Dartford
    Posts
    221
    Thanks
    3
    Thanked 14 Times in 14 Posts
    Well your sending the information form: www.dishonor-elite.com to www.dishonor-elite.com/forums/

    So you need to make the login fileds on www.dishonor-elite.com post then to the fourm so you may need to edit the forum, useing $_GET or $_REQUEST in the text fileds to get the information.

  • #5
    New to the CF scene
    Join Date
    Aug 2006
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    because i do not understand php as of yet, what u said doesnt make sense to me. can you maybe explain in depth?
    if not, then i guess ill just have to live with it untill i learn the php language!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •