Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7

Thread: I'm confused

  1. #1
    New Coder
    Join Date
    Sep 2005
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I'm confused

    I downloaded and installed phpdev. I tried making my first php file

    Code:
    <html>
    <body>
    
    <?php echo "Hello World"; ?>
    
    </body>
    </html>
    then saved it as helloworld.php and put it in the www folder for that package. Then went into the browser and typed "http://localhost/helloworld.php" it then came up with an error saying "connection was refused when attempting to contact ....."

    All this time the Apache server was running.

    I use Mozilla Firefox.

    Can someone please help!!!

    I AM AN ABSOLUTE BEGINNER!!!

  • #2
    raf
    raf is offline
    Master Coder
    Join Date
    Jul 2002
    Posts
    6,589
    Thanks
    0
    Thanked 0 Times in 0 Posts
    did you try shutting down and restarting apache?
    do you have a firewall running?
    Posting guidelines I use to see if I will spend time to answer your question : http://www.catb.org/~esr/faqs/smart-questions.html

  • #3
    New Coder
    Join Date
    Sep 2005
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yes I did try shutting down and restarting.

    And I do have a firewall (Norton) but i allowed it to let the things is wanted through.

    Has anyone else had this problem?
    Last edited by Gnatfish; 09-11-2005 at 01:51 PM.

  • #4
    New Coder
    Join Date
    Sep 2005
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I decided to check what happened in Opera and it said this:

    "Could not connect to remote server"

    I am really stuck - help please!!!

  • #5
    raf
    raf is offline
    Master Coder
    Join Date
    Jul 2002
    Posts
    6,589
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i only get such errormessages on my localhost if my webserver is not running or inaccesible.

    try disconnecting your machine from the web, shut down your firewall or set it in "allow all communications" mode.
    then make sure apache is running and try again.
    Posting guidelines I use to see if I will spend time to answer your question : http://www.catb.org/~esr/faqs/smart-questions.html

  • #6
    Senior Coder missing-score's Avatar
    Join Date
    Jan 2003
    Location
    UK
    Posts
    2,194
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The official Phpdev forums are here: http://www.firepages.com.au/FUD/index.php , so if you are having trouble you may find better answers on there

  • #7
    New Coder
    Join Date
    Sep 2005
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you raf. Its working now. Thanks!!!!!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •