Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New Coder
    Join Date
    Nov 2003
    Location
    RP, Manila
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Helpy, my (FS) site, www.mexico31.com is stuck

    hello,

    i need help about my site, i use php to toss and dice data, once you have entered the "my blog" area, pls type on your uri: "mb.php". As you can see the data have been successfully queried, however: it couldnt be retrieved properyly by the FS file?? How come this happens is i dont know.

    Though i did a thorough test on my PC, where it did successfully toss and diced the data. on server-side -- its my first time with FS-PHP-MYSQL technique. I hpe somebody could help me.

  • #2
    Regular Coder
    Join Date
    Feb 2005
    Location
    West Midlands, UK
    Posts
    623
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'm getting a 404 for mb.php, but if you say the script is successfully generating the data and it worked on your home system then there's a good chance it's not a PHP issue. Either way it would be useful to see some code.

  • #3
    New Coder
    Join Date
    Nov 2003
    Location
    RP, Manila
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    yes, i do agree it isnt php....

    yes, php seems to not liable for this issue. If you coudnt find the mb.php, its on the root: http://www.mexico31.com/mb/mb.php, however you must first load the initial first page which is http://www.mexico31.com/mb/. Once this page initially load, the swf file uses the loadVariables() method to call the mb.php script as found from the uri above. Then after the former uri loaded go to mb.php and you can see that the variables and value pairs are successfully called upon.

    I did a trial on loadVariablesNum() method on Flash to change the old method ive used, but it still didnt worked. I used loadVariablesNum() since i did a quick reseach that a forum said that loadVariables() method seems to oddly not working, heck whats' the real macromedia documentation.

    Anyway, i do agree that php is not in fault to this. Thats why i tryied to post it on Flash forrum of our CF, hoping some actionScripter would notice me, but lol, they threw me out to php.

    Lol!


    ----------
    Oh i forgot, i did deliberately use a 404 error page so as to confuse others peeps from seeing the mb.php, so that's why you see what i wanted you to see. You wouldnt see the variables and value pairs on mozilla, or netscape i think as ive tried it. Pleas use IE to see the mb.php. Lol, i got you there, he he he! The 404 error is deliberate.

    You would have to see a part of this message BELOW the 404 page: (just a part of everything on it):::

    &id0=2
    &row0title=The+Inaugural&row0dates=06.12.05&row0blog_text=Let+me+first+present+to+you+%3Cbr%3Eladies +and+gents+the+specification+%3Cbr%3Eof+my+beloved+new+blog+site%3A%3Cbr%3EProject+Name%3A+mexico31% 3Cbr%3EProject+Development+Span%3A+Nov...&row0disp=Let+me+first+present+to+you+%3Cbr%3Eladies+and+ge nts+the+specification+%3Cbr%3Eof+my+beloved+new+blog+site%3A%3Cbr%3EProject+Name%3A+mexico31%3Cbr%3E Project+Development+

  • #4
    New Coder
    Join Date
    Nov 2003
    Location
    RP, Manila
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    php: Asks for three most recent blog on db

    heres the code on php, hope this would help,

    the code on Flash is that its like this:
    action = "askThree";
    loadVariables("mb.php", this, "POST");

    i did used the Num thing:
    whilst, please be NOTED that both method works on my Local System:

    action = "askThree";
    loadVariablesNum("mb.php", 0, "Post");

    -----------------
    function askThree() {
    $table = "blog_main";
    $query = "select id, title, date, blog_text from $table order by datum desc limit 3";
    $result = mysql_query($query);

    if (!$result) {
    fail("Failed to retrieve data, please try again.");
    }

    $count = 0;

    while($row = @mysql_fetch_array($result)) {
    $titolo = stripslashes($row['title']);
    $araw = stripslashes($row['date']);
    $blogs = stripslashes($row['blog_text']);

    $stripped = substr($blogs, 0, 158);

    $id = $row['id'];

    $ider[$count] = $row['id'];
    $id0 = $ider[0];
    $id1 = $ider[1];
    $id2 = $ider[2];

    print "&id".$count."=$id<br>";

    print "&row".$count."title=".urlencode($titolo);
    print "&row".$count."dates=".urlencode($araw);
    print "&row".$count."blog_text=".urlencode($stripped)."...";
    print "&row".$count."disp=".urlencode($blogs);

    $count++;
    }

    print "&blogCount=$count";
    print "&result=Okay";
    }

  • #5
    Regular Coder Coastal Web's Avatar
    Join Date
    Oct 2004
    Posts
    225
    Thanks
    12
    Thanked 3 Times in 3 Posts
    Hello frio_ej,

    I'm going to ask a few questions, because l'm not 100% clear on what the issue is...

    I've visited the site:
    http://www.mexico31.com/mb/

    And noticed that the external content continues to load, indefinetly...

    However if l click on the "my blog" button it loads up automatically without a problem. So my question is, are you having issues with the fact that the content doesn't load until the user clicks on the "my blog" button near the top of the page?


    Samantha Gram

  • #6
    New Coder
    Join Date
    Nov 2003
    Location
    RP, Manila
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    thank you

    im sorry if i havent replied hastly enough....

    my domain is currently suspended for unpaid bills. lol.

    that page, "my blog" was supposed to load automatically. well maybe my flash code wasnt complete then,

    then if that is the case: i should have put this sort of thing: (a pseudocode sort)


    on.dataLoad(thisClip) {
    goToAndStop(frame_Where_my_blog);
    }

    if you have successfully tried to click the my blog button where it forces it to go to that frame where it would display the my blog page, then perhaps my automatic loading (as pseudocoded above) wasnt good enough.

    perhaps that's the case then... on my flash codes.

    ------------
    jst one last favor:

    id like to confirm to Samantha if you have really have seen and successfully loaded the text when you have clicked the my blog button???

    because that's where im gonna head straight to debug my flash, if its the case then.

    -----------

    thank you so much folks for your helps, if there is anything i could do in return. its actually our Filipino custom to return favors, with our sincere hearts.

    how about a link then. or anything else. if there is none, id like to thank you guys!!!!!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •