Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New Coder
    Join Date
    Aug 2013
    Posts
    36
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Can't login to website once hosted online

    I've been trying to build a website and it isn't coming easy.

    I've built it using my localhost as a server using firefox for testing. I thought I was getting close to the end on the app side of the website however after testing on different browers I have issues.

    At that point I thought I would upload it to a free host and try it live and online. I'm using 000webhost and have used them in the past but never for a site like this. So maybe its because of them I don't know.

    After changing all references to my database to the database on 000webhost and uploading it to their servers I can no longer log into the website.

    When I enter a username and password it only reloads the top portion of the website. Here's a link to it, if anyone has any ideas it would be appreciated.

    http://a2b.net78.net/login.php

  • #2
    New Coder
    Join Date
    Aug 2013
    Posts
    36
    Thanks
    6
    Thanked 0 Times in 0 Posts
    the login that should work is

    username: chase
    password: chase

  • #3
    Senior Coder CFMaBiSmAd's Avatar
    Join Date
    Oct 2006
    Location
    Denver, Colorado USA
    Posts
    3,043
    Thanks
    2
    Thanked 316 Times in 308 Posts
    Posting your code would be the quickest way of determining what the code is doing that would not be portable between different servers.
    If you are learning PHP, developing PHP code, or debugging PHP code, do yourself a favor and check your web server log for errors and/or turn on full PHP error reporting in php.ini or in a .htaccess file to get PHP to help you.

  • #4
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,987
    Thanks
    4
    Thanked 2,660 Times in 2,629 Posts
    ^
    Since we cannot see your code when served from a webserver, the only way to troubleshoot is to see the code itself. My immediate guess is the use of register globals or code relying on it (such as session_register), but that is not the only cause for such issues.
    PHP Code:
    header('HTTP/1.1 420 Enhance Your Calm'); 

  • #5
    Regular Coder
    Join Date
    Aug 2012
    Posts
    142
    Thanks
    39
    Thanked 3 Times in 3 Posts
    My guess is that your connection to the remote site is still using the user and password from the local. It's highly unlikely that they are the same.

  • #6
    Senior Coder CFMaBiSmAd's Avatar
    Join Date
    Oct 2006
    Location
    Denver, Colorado USA
    Posts
    3,043
    Thanks
    2
    Thanked 316 Times in 308 Posts
    Quote Originally Posted by robsworld78 View Post
    After changing all references to my database to the database on 000webhost and uploading it to their servers I can no longer log into the website.
    You should have your database credentials in an included file so that they are defined in only one place, with only one place to change when needed.
    If you are learning PHP, developing PHP code, or debugging PHP code, do yourself a favor and check your web server log for errors and/or turn on full PHP error reporting in php.ini or in a .htaccess file to get PHP to help you.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •