Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Aug 2012
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Php Script Help needed

    Is their any person who can solve this
    Code:
    /home/ohmbuxco/public_html/royaltyhits.com/view/theme/default/tpl/index.php
    
    Fatal error: Uncaught exception 'Exception' with message 'no template file index.php present in directory 
    /home/ohmbuxco/public_html/royaltyhits.com/view/theme/default/tpl/' in /home/ohmbuxco/public_html/royaltyhits.com/ClixScript_PHP_DOCS/classes/class.view.php:169 Stack trace: #0 
    /home/ohmbuxco/public_html/royaltyhits.com/ClixScript_PHP_DOCS/controller/index.php(11): View->render() #1 
    /home/ohmbuxco/public_html/royaltyhits.com/ClixScript_PHP_DOCS/classes/class.router.php(154): include('/home/ohmbuxco/...') #2 
    /home/ohmbuxco/public_html/royaltyhits.com/router.php(15): Router::load() #3 
    {main} thrown in /home/ohmbuxco/public_html/royaltyhits.com/ClixScript_PHP_DOCS/classes/class.view.php on line 169

  • #2
    Regular Coder Custard7A's Avatar
    Join Date
    Jul 2010
    Location
    Australia
    Posts
    286
    Thanks
    32
    Thanked 33 Times in 33 Posts
    It sounds like you are using a template system with a misconfigured directory system, pointers to directories, or just plain missing some files.

  • #3
    New to the CF scene
    Join Date
    Aug 2012
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    can u help it on

  • #4
    Regular Coder Custard7A's Avatar
    Join Date
    Jul 2010
    Location
    Australia
    Posts
    286
    Thanks
    32
    Thanked 33 Times in 33 Posts
    I can't pull answers from thin air. What you have posted so far has no dialogue, I can only make wild guesses.

    Have you made recent changes to your code or website that seem to happened at the same time as the error? Are you recently — or even in the process of — installing a ClixScript setup on your site? Do you understand much PHP? Your script is expecting a template file (index.php it seems) to be in the directory "/home/ohmbuxco/public_html/royaltyhits.com/view/theme/default/tpl/", is that where your template files are, or does that sound right to you?

    You need to help us, if you want us to help you. Fixing a problem requires information.

  • #5
    New to the CF scene
    Join Date
    Aug 2012
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    When i reported to script developer abt this issue they told

    /home/ohmbuxco/public_html/royaltyhits.com/view/theme/default/tpl/index.php

    u have this file? it must be in that directory,...

    you could perhaps try to make template name royaltyhits instead of royaltyhits.com im not sure if the dot might mess up

  • #6
    Regular Coder Custard7A's Avatar
    Join Date
    Jul 2010
    Location
    Australia
    Posts
    286
    Thanks
    32
    Thanked 33 Times in 33 Posts
    Well, yeah. You should be making sure you have that file there (First thing you should be doing), and creating a folder with a period in the name may cause unexpected behaviour (Not something I've done, but a period has special meaning in other ways in URLs), so you should change it to be sure.

    Sounds like the script developer is on the right track.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •